Originally posted by BB_foxbox:
@Jimah
No, I'm afraid your problem is different - and very unique so far
I assume you get the same error on skirmish maps?
When you're in the main menu is anything (settlers, birds) moving on the background map?

@GameOverRIP
Dynamic IP should be just fine - we tested on DSL lines and with 24h disconnects...
Are you absolutely sure you cannot reach the second link I posted?
Yeah unfortunately the second link just goes to a Webpage not Found error thats on IE8 haven't tried any other browser

not behind any firewalls/proxy's either also tried with and without my wireless router and no different

The webpage cannot be found
HTTP 404
Most likely causes:
•There might be a typing error in the address.
•If you clicked on a link, it may be out of date.

What you can try:
Retype the address.

Go back to the previous page.

Go to and look for the information you want.

More information

This error (HTTP 404 Not Found) means that Internet Explorer was able to connect to the website, but the page you wanted was not found. It's possible that the webpage is temporarily unavailable. Alternatively, the website might have changed or removed the webpage.

For more information about HTTP errors, see Help.