1. #1
    Hello,

    I used to have XP and now have 64 bit Vista and now my Warrior Within and Two Thrones games no longer work. The funny thing is my Sands of Time game still works. The Assassins Creed and new Prince of Persia games work great but my two older ones won't install. It says something about not having a proper driver version for a Starforce driver or something. Any ideas?

    Thank you
    Share this post

  2. #2
    Hello,

    I used to have XP and now have 64 bit Vista and now my Warrior Within and Two Thrones games no longer work. The funny thing is my Sands of Time game still works. The Assassins Creed and new Prince of Persia games work great but my two older ones won't install. It says something about not having a proper driver version for a Starforce driver or something. Any ideas?

    Thank you
    Share this post

  3. #3
    kakalukiaJay's Avatar Most Helpful Prince of Persia Community Member
    Join Date
    Apr 2004
    Posts
    4,814
    That question was recently asked in another thread where someone replied with a URL where to get newer StarForce drivers for Windows Vista.
    Remember, the game was programmed, tested, and certified for Windows 2000 and XP ... not Vista.
    There are other discussions regarding multiple cpus and other hardware changes since the earlier games have been published.

    It demonstrates the "lack of concern" from various hardware and software companies for legacy compatability.
    Companies want to sell to you newer this and faster that without regard to "older favorites."
    Share this post