Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46

Thread: Rainbow six vegas 2 blackscreen problem..... | Forums

  1. #1
    Junior Member
    Join Date
    May 2009
    Posts
    6
    My brother-in-laws computer, works with everything including 3 other games (vegas1, lego batman, Fallout 3).

    With Vegas 2 however he gets a black screen after the screen where the outline guys are walking and the game is loading. He should get the splash screen and the message "hit any key" but his stays black and you have to hard reboot in order to do anything.

    64 bit vista, core 2 quad, 6 gigs of ram, ATI 3650 video card.

    I would think this is a driver issue but it looks as though we have the current video drivers (works with 3 other games, including vegas 1) and the latest game patches.

    Any idea would be appreciated. I have the game on my system and enjoy playing online with another friend that has it on his.

    I know my brother-in-law would enjoy it as well
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    May 2009
    Posts
    6
    update.

    We have now tried the store bought disk and downloading it from Steam with no luck.

    We also tried this game with an ATI 4850 card with the same results.
    Reply With Quote Reply With Quote

  3. #3
    While you get the black screen, do you have the background music playing?
    Or is it completely frozen?

    What are the rest of the machine specs?
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    May 2009
    Posts
    6
    No sounds in the background, Completely frozen computer as far as we can tell


    Dell XPS 430
    Processor Intel® Core™2 Quad 2.5GHz

    System Bus 1333MHz

    System Memory 6GB PC3-8500 DDR3

    Hard Drive Serial ATA (7200 rpm)Hard Drive Size
    750GB
    Graphics ATI RADEON HD 3650 256MB (dedicated)

    Audio High-definition audio (7.1-channel support)

    Network Card Built-in 10/100/1000 Ethernet LAN
    Recordable DVD Drive DVD±RW/CD-RW Recordable DVD Drive Speeds 16x8x16 DVD+RW; 16x6x16 DVD-RW; 48x4x48 CD-RW

    Digital Media Reader or Slots
    Yes, digital media card reader

    Total Expansion Slots
    2 PCI, 1 PCI-E x1, 1 PCI-E x8, 2 PCI-E x16

    USB 2.0 Ports 12 (2 front, 5 rear, 5 internal)

    OS Windows Vista Home Premium 64-bit with SP1
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Feb 2003
    Posts
    15
    Hey, I have a similar system and just started having the same problems.

    I have played it a long time with no problems, one day I come home and the game stutters and lags like crazy.

    The main thing I see before the slow performance or just the black screen is the warning message "online play can be different, or something like that" goes to bright white, and than when it starts dimming it basically blacks the screen and freezes the game to a "not responding" state.

    Even a full re-install of windows and the game has not fixed this. I am really thinking it is the DVD player now, but if I use the NO-CD exe it does the same thing.

    Anybody have a solution to this?

    Richard
    Reply With Quote Reply With Quote

  6. #6
    Junior Member
    Join Date
    Feb 2003
    Posts
    15
    I just figured out that the game is using one of my cpu for 100% and get a "not responding" in the taskmanager. Today I did hear the sound and when I hit a key i did hear it go to the next screen. It remains black though?

    Looked at the video card drivers and they are from 5/30, so the newest drivers are loaded. I might try some other drivers.

    Is it possbile to run this from a virtual disc?

    Richard
    Reply With Quote Reply With Quote

  7. #7
    Are you both using Vista 64?

    I'm using Vista 32 home premium with no problem and I was using XP before also without problems.

    This sound to me like a driver problem, I have often read here that other people tell that the SOUND drivers were the problem for their freezes.
    Reply With Quote Reply With Quote

  8. #8
    Junior Member
    Join Date
    Feb 2003
    Posts
    15
    I'm downloading the newest audio drivers now and will report back if it worked.

    I have ran a videocard test with Performance Test 7.0 and it seems that the 3d complex test will not run, while all other tests run fine. I cannot pinpoint exactly what this tests is trying to use though.

    Thanks for the tip.

    Richard
    Reply With Quote Reply With Quote

  9. #9
    Junior Member
    Join Date
    Feb 2003
    Posts
    15
    Funny now stops on the "loading" screen. I have perfect sound in the back, but do not see the game, it's a black screen.

    If I run this game in compatibility mode for XP SP2 it will not see the DVD drive somehow.

    Running out of options, I might just go back to windows XP, I like this game and want to play it.

    Richard
    Reply With Quote Reply With Quote

  10. #10
    This is a real head scratcher.

    It still seem like a driver problem.

    Have you checked ATI forums? It might be that your particular card has issues with Vegas2 that have not been addressed in the latest drivers yet.

    Have you tried contacting UBI support? I know a lot of people here have said UBI is no help, but in my experience, UBI support has come through for me in the past.
    Reply With Quote Reply With Quote

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •