This happened to me too, being that we just got a new pc with XP on it, and I wanted to play. The solution is at http://support.ubi.com/. Here is the entire posting and reply:
"Every time the game loads, it's upside down. What do I do?"

The capability to invert the display is a feature of the Intel i845 video chipset. Rotation is enabled by default and is activated by the default key combination down, hence why the display may rotate when playing certain games with the keyboard. If you are experiencing this problem, you can disable the rotate feature.

To disable the Rotate feature, right click the Intel Extreme Graphics icon on the taskbar, select Graphics Options, then Graphics Properties. Click on the rotation tab and remove the tick from the enable rotation box. Alternatively it can be accessed from Display Properties - Settings - Advanced - Intel Extreme Graphics - Graphics Properties.

You know what? IT WORKS!