Results 1 to 6 of 6

Thread: FC Crashing with lighting set to "very high" quality | Forums

  1. #1
    If anyone can help I'd sure appreicate an answer. I seem to just keep getting directed to do more searches for an answer. I can't find one, so if you know what might fix this problem please just tell me.

    Whenever I patch to 1.3 or higher, the game will just freeze at the splash screen (the one with black background) if lighting quality is set to "very high". I want to play a patched version so I can enable HDR lighting.

    Also, I have not been able to get HDR to work at all. I tried enabling it in versions 1.3, 1.31, 1.33, and 1.4 (beta patch)to no avail.
    With lighting set to high (very high will crash game)I enter the \r_hdrrendering # command in the console and it is accepted, but nothing changes on the screen. If lighting at very high is required for HDR then I guess I need to fix that problem to use HDR lighting.

    I have the latest version 6.9 of the ATI catalyst installed and all hardware has updated drivers. Computer is stable and has a fresh install of XP SP2 installed. Video card is X1900 XT, and with my other hardware I should be able to enable HDR and run this game with ease and not have these crashes.

    Thanks for any assistance.<div class="ev_tpc_signature">

    AMD 64 X2 4200+ @ 2.3 GHz
    2 GB Corsair XMS2 DDR2-800
    Asus M2N SLI Deluxe mobo (bios ver 0307)
    X1900 XT
    WD 250 GB SATA HD

  2. #2
    Senior Member IceT-Bag's Avatar
    Join Date
    Jun 2004
    Im not sure why you game crashes with HIGH light settings with that card, as its pretty much the dogs meat n veg isnt it

    Only thing I would suggest is running "dxdiag" to see if any DirectX related issues are highlighted.

    Hopefully another user with the same card can offer something more useful.

    With regards to HDR, I've never fiddled with getting HDR to work in farcry, but I can confirm that the OFFICIAL 1.4 patch has NO SUPPORT for HDR (it was removed as it was buggy).

    IceT<div class="ev_tpc_signature">

    Im a Bomb Disposal Officer, if you see me running - try to keep up! - virtual home of the [22ndSAS]


  3. #3
    Actually, everything on very high except lighting works just fine. It's only when the lighting is set to very high that the problem occurs.

    I've kept looking, but I can't seem to find a solution to this problem. I guess I'll just play it without the HDR and look at the pretty lights on a newer game that was actually meant to use HDR from the start.<div class="ev_tpc_signature">

    AMD 64 X2 4200+ @ 2.3 GHz
    2 GB Corsair XMS2 DDR2-800
    Asus M2N SLI Deluxe mobo (bios ver 0307)
    X1900 XT
    WD 250 GB SATA HD

  4. #4
    WOW i have the same problem. I also have x1900xt and 6.9 drivers. The thing that does it is the bump mapping quality. It cannot be set to 3. "Customise" the lighting settings in the configuration utility and put the bump mapping value to 2, everything else can be as it would in "very high" mode. Now it should run, but HDR still wont work as it needs bump mapping at 3. I also get a blue line up the left and along the top of the screen when i'm outside, do you get this?

  5. #5
    Senior Member Smellf's Avatar
    Join Date
    Apr 2005
    I would say its an issue with your graphics card or drivers. Have you tried using older drivers?<div class="ev_tpc_signature">


    Keep it UnReaL

  6. #6
    I don't get the "blue line" thing, that's kind of weird.

    I got HDR woking (kind of) with this card and 6.9 drivers. I had to do a system restore back to before I installed any video drivers to make sure there wasn't some bit of an older driver or something else causing a problem. I re-installed Catalyst 6.9.Then I reinstalled the game and the "official" patch 1.4. Lastly, I installed the latest Direct X.

    The weird thing is HDR seems to only work for me on certain "levels" of the game. It wouldn't work in the initial training missions, but it came on in the early level after the carrier where you start in the orange boat. I played with it on for a while but it makes the lights indoors so bright that it's blinding sometimes so I turned it off. I tried to turn it back on on the "cooler" level but it wouldn't come on again.

    From what I saw of it in this game I'll just leave it off. I mainly just wanted to see what it would look like and if my system would slow down much with it enabled (it didn't). I'll wait for other games that were designed from the beginning to use HDR lighting before I mess with it again.

    BTW, FSAA and HDR would not work together in this version. With HDR on, I could enable FSAA all I wanted but the settings wouldn't "take" in the game.<div class="ev_tpc_signature">

    AMD 64 X2 4200+ @ 2.3 GHz
    2 GB Corsair XMS2 DDR2-800
    Asus M2N SLI Deluxe mobo (bios ver 0307)
    X1900 XT
    WD 250 GB SATA HD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts