Page 1 of 5 123 ... LastLast
Results 1 to 10 of 49

Thread: [Mac] Myst IV Installation problem | Forums

  1. #1
    Hey Guys,
    i'm a brandnew Mac-User and i've seen that my Myst IV is also for Mac. I have the new MacBook Pro 15" with 2.66 ghz and Mac OS X 10.5.8

    Ok, now the problem. I inserted the disc 1 and copied the installation file onto my desktop. I double-clicked it and in the dock the icon appeared. But then it bounced one time and disappears. Nothing happens. I looked for some fixes to run it on leopard, but for all these fixes i have to install it, right?

    I really hope that someone can help me!
    Reply With Quote Reply With Quote

  2. #2
    Senior Member
    Join Date
    Nov 2003
    Location
    Fountain Valley, CA
    Posts
    1,615
    Aren't you supposed to run the installation program from the disc rather than from your hard disk's desktop?
    -------------------------------------------
    Fear leads to anger; anger leads to hate; hate leads to SUFFERING! - Yoda
    Reply With Quote Reply With Quote

  3. #3
    When i click on the cd icon on my desktop, then this installation window opens. theres the setup file and besides text which says in many languages that i have to drag this file onto my hdd and then to open the set up file from my hdd. i've tried to open it from dvd, but then only a window opens with exactly the same text like in the window before.
    Reply With Quote Reply With Quote

  4. #4
    Senior Member
    Join Date
    Nov 2003
    Location
    Fountain Valley, CA
    Posts
    1,615
    You are right, I remembered wrong. My disc is the same as yours. I'm guessing (again) that somehow Leopard treats the setup program differently than Tiger. Or maybe Intel Macs do not speak Myst. The Mac System Requirements on page 4 of the Myst IV manual says the application runs on Mac OS 10.2 and 10.3 only. However it installs and runs fine under my OS v 10.4.11. But then I am also on a PowerPC Mac, not an Intel Mac.

    Try this website, it has to be more helpful than I am. http://www.mystcommunity.com/b....php?showtopic=29059
    -------------------------------------------
    Fear leads to anger; anger leads to hate; hate leads to SUFFERING! - Yoda
    Reply With Quote Reply With Quote

  5. #5
    The MYSTcommunity post may help, and you can also do a search there for your problem.

    Some additional possibilities:
    1. Try doing an Advanced Search in this (Myst IV Revelation - Technical Help & Advice) Forum.
    -- a. At the top of the Forum page, click on the Find tab, then click on Advanced Search.
    -- b. Type your search words into the Search Words: with all of the words box. Mac Intel Leopard or MacBook are good starting choices.
    -- c. For Search by:, scroll down to and click on Myst IV Revelation - Technical Help & Advice to highlight it. Then click on a blank area to lock in your Search by: selection.
    -- d. Click on the Search within: Subjects and Messages radio button to activate it if not already activated.
    -- e. Click on the Order By: Date radio button to activate it.
    -- f. Uncheck the Post Types: Polls and Photo Albums boxes.
    -- g. Uncheck the Search Results: Group Posts by Topic box.
    -- h. Click on the Search button (immediately below Search Results: Group Posts by Topic).

    2. Go to Apple Discussion and ask your question and/or search for answers. Myst and Revelation are good starting choices.
    -- Mac OS X v10.5 Leopard (For example, Myst IV stopped working.)
    -- MacBook

    If you're not familiar with using the Terminal, some tutorials are available here (scroll down the page).
    Heimdall
    Semper ubi sub ubi
    Reply With Quote Reply With Quote

  6. #6
    Senior Member JacaByte's Avatar
    Join Date
    Oct 2005
    Posts
    605
    Originally posted by wstrohm:
    Or maybe Intel Macs do not speak Myst.
    Huh?

    I suspect that the problem lies with the fact that Myst has no binary compatibility with Intel Macs. I'd try Getting Info (cmd + I) on the installation program and turning on Rosetta for the application from there, if you haven't already.
    To the world, you are only one person. But to one person, you are the world. ~unknown
    Reply With Quote Reply With Quote

  7. #7
    Hi there,

    I'm having the exact same problem getting the installation to launch (I also have a MacBook Pro). I looked through all the forums, but still haven't seen any solutions.

    MrMcNugget, were you ever able to get it to work?

    Thanks!
    Reply With Quote Reply With Quote

  8. #8
    No, i installed Mac OSX 10.6 now and installed Rosetta again, but still the same problem and in the other forums i just found solutions when the game is already installed. I installed windows on another partition on my hdd, i will install it there.
    Reply With Quote Reply With Quote

  9. #9
    Junior Member
    Join Date
    Sep 2009
    Posts
    2
    I am also unable to install fresh Myst IV on Snow Leopard, and even on an upgraded-from-Leopard MacBook, the game will no longer launch on Snow Leopard.
    Reply With Quote Reply With Quote

  10. #10
    Senior Member
    Join Date
    Nov 2003
    Location
    Fountain Valley, CA
    Posts
    1,615
    After playing Myst IV successfully since its release, my recent re-formatting of the hard disk on my computer required me to re-install the game. Unfortunately, dragging the "MystIV_Setup" icon from the Disc #1 splash screen to my Games folder and then double-clicking it results in a momentary opening of the app for about 1 second, then it closes.

    Found some other stuff that looks tough to solve... see my post in an adjacent thread.

    This is on my PPC PowerMac 2.7 GHz dual-CPU G5. Have installed and played the game on this computer before, and never had this problem. Have read about the "chmod a + xMyst4" trick, but that is for the game itself... which isn't on my computer because the installer doesn't work.

    I noticed one odd thing: If I replace the MystIV_Setup.app" file with another drag and drop from the DVD, I get a message that the one on the hard disk is "newer," and do I want to replace it with an older file? All I did was drag & drop it... how does that make it "newer" than it was a minute ago?
    -------------------------------------------
    Fear leads to anger; anger leads to hate; hate leads to SUFFERING! - Yoda
    Reply With Quote Reply With Quote

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •