Page 8 of 8 FirstFirst ... 678
Results 71 to 76 of 76

Thread: how to get il21946 to work with win7 FIX | Forums

  1. #71
    Global Moderator Tully__'s Avatar
    Join Date
    Nov 2003
    Posts
    15,793
    Have you run the securom update for Win7?
    After running the securom update, did you try navigating the DVD to find the file a.exe and running that instead of setup.exe?
    Reply With Quote Reply With Quote

  2. #72
    Junior Member
    Join Date
    Jun 2012
    Posts
    3
    No, the only thing I tried was downloading the disk to a file on my C drive, titled Il-2Games.

    The PC was only delivered this week, would it need the securom update already? Which is to say, do I even have it installed? Thinking about it, how would I check I've even got it on my system? Does it download with IL-2? I don't recall installing it or registering my copy on my lappy?
    I've since deleted the whole file- just before posting on here. Would the thing leave any trace. (A quick glance at wiki has dire warnings about it not un-installing...)
    Reply With Quote Reply With Quote

  3. #73
    Global Moderator Tully__'s Avatar
    Join Date
    Nov 2003
    Posts
    15,793
    There's only one registry entry for IL2, the language setting. If the disk wont install with an error "already installed", you'll have to delete that from registry.

    Unless you have a US printed DVD, securom is part of the IL2 installation. There's no sign that it's installing ('cept maybe a Windows notice that "driver installation is complete" during the game install) until you get an error that a driver is not compatible with Windows 7. It's been so long since I re-installed I don't remember the exact error. The link in the first post of this thread is for a securom support page that has a tool for download that'll help you sort it out if you're getting this error (this one: https://support.securom.com/analysis.php).
    Reply With Quote Reply With Quote

  4. #74
    Junior Member
    Join Date
    Nov 2012
    Posts
    2
    I have been trying to install 1946 on Win7_64 for about 2 months now, and it's driving me nuts.

    - I am installing from a.exe on a separate partition, in a folder called "Program files" but which is NOT under c:\

    - Installation goes through OK, but when I try to start the game, the load circle just spins for a 3-4 secs and then disappears. I suspect it could be a SecuROM issue. No error messages displayed.

    - I have installed the SecuROM Diagnostic software, and when I run it it does recognize IL-2 BUT when I click "Update" in analyzer and start the analysis, IT SAYS "ABORTED BY USER" already during the first step. I obviously haven't touched it. (During Diagnostic startup it says something about failing to connect to SecuROM server, although my internet connection is fine.) Same thing regardless of whether I'm running the diagnostic as an admin or as a regular user.

    I'm stuck and out of ideas. Help me, or I have to buy a Playstation.
    Reply With Quote Reply With Quote

  5. #75
    Global Moderator Tully__'s Avatar
    Join Date
    Nov 2003
    Posts
    15,793
    Check that your firewall isn't blocking the Securom diagnostic software.
    Reply With Quote Reply With Quote

  6. #76
    Junior Member
    Join Date
    Nov 2012
    Posts
    2
    Good suggestion, but that doesn't seem to be the problem, either. When I start the SecuROM Diagnostic Tool it says "Connection to the SecuROM support tool server failed", although web connection is on and I have given it access through the Windows firewall both in the Control Panel and during program startup.

    I have F-Secure virus & malware protection running as well, but it should also notify about suspicious activity first, and Diagnostic Tool does not appear in the logs.
    Reply With Quote Reply With Quote

Page 8 of 8 FirstFirst ... 678

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •