Results 1 to 10 of 10

Thread: Why won't my torpedo's explode (or the ships sink?!) | Forums

  1. #1
    Junior Member
    Join Date
    Apr 2005
    Posts
    8
    First of all, I have Dud torpedoes -setting turned on, so I expect some duds.. BUT! My problem is:
    When I literally cripple for example a coastal merchant ship, so that it doesn't move and it's caught on fire, I stay for hours in the same spot (on surface) and the darn thing won't sink. Neither do I get any report that the ship would have been destroyed. So then in frustration I try to shoot yet another one torpedo to it and Behold!! I wasted a whole 4 torpedos on that one ship, and none of them exploded.

    And it has happened twice. The most recent I shot a C2 cargo ship, so that two torpedoes hit it in the aft and it still kept moving on though it was leaning on it's right side. It was making evasive maneuvers so I had to go to it's side and when I shot the other torpedos (three of them) they didn't explode.

    In both cases (Where I wasted the torpedos) I was about 400m away from the ships, so that I could see from the deck that those torpedos went right to the side of the ship. So the wasting of those torpedos is really, I mean REALLY frustrating!

    Anyone else having these problems? Or does someone know WHY these problems incur? I have the 1.2 patch.

    Please, be so kind and take a little time to answer my problems. Thank You.
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    Apr 2005
    Posts
    8
    First of all, I have Dud torpedoes -setting turned on, so I expect some duds.. BUT! My problem is:
    When I literally cripple for example a coastal merchant ship, so that it doesn't move and it's caught on fire, I stay for hours in the same spot (on surface) and the darn thing won't sink. Neither do I get any report that the ship would have been destroyed. So then in frustration I try to shoot yet another one torpedo to it and Behold!! I wasted a whole 4 torpedos on that one ship, and none of them exploded.

    And it has happened twice. The most recent I shot a C2 cargo ship, so that two torpedoes hit it in the aft and it still kept moving on though it was leaning on it's right side. It was making evasive maneuvers so I had to go to it's side and when I shot the other torpedos (three of them) they didn't explode.

    In both cases (Where I wasted the torpedos) I was about 400m away from the ships, so that I could see from the deck that those torpedos went right to the side of the ship. So the wasting of those torpedos is really, I mean REALLY frustrating!

    Anyone else having these problems? Or does someone know WHY these problems incur? I have the 1.2 patch.

    Please, be so kind and take a little time to answer my problems. Thank You.
    Reply With Quote Reply With Quote

  3. #3
    Senior Member
    Join Date
    Dec 2002
    Posts
    612
    If you are trying it hit the side, make sure you are hitting it as close to 90 degrees into the side as possible. Shallow angle shots will just bounce off.

    Also, don't get "too" close to the ships. Torpedos have a minimum safe distance of 300 m before they arm themselves. They'll never explode before they travel 300 m.
    Reply With Quote Reply With Quote

  4. #4
    Are your torps. set to impact or impact + magnetic (on the TCD screen)? The impact + magnetic pistol setting is the default setting. If its on I+M what depth do you have the torps running? You want them to be below the ships draft about 1M or so. This way they will explode under the ship giving it more damamge. I've also set my torps to just impact and the depth to the lowest possible setting...that seems to work for me in certain situations. Distance is also important.
    Reply With Quote Reply With Quote

  5. #5
    Senior Member blue_76's Avatar
    Join Date
    Nov 2004
    Posts
    2,260
    I generally have better luck with torpedoes if i am setup for an attack at a good angle of bearing to the ship.. if the ship is less than 45deg or greater than 155deg the torpedo will have very little chance of going off.. another thing that helps is setting the fuse to impact at the tdc screen and the speed to fast (if its a steam torpedo). also, some ships are more easily sunk with a magnetic fuse directly under the keel say about 1 meters.. others are more vulnerable with shots at their engines.. hope this helps you. good luck!
    Reply With Quote Reply With Quote

  6. #6
    This happens to me, too. My magnetic torps were deflecting off the sumberged, partially-sunk hull because the angle they were hitting as the hull curves away under the surface was too great. I switched my "one more fish to finish 'er off" shots to Impact Only, 4m depth for merchants. If the target is listing, I maneuver to the side away from the list. This decreases the chance of the torp defectling off the hull.
    Reply With Quote Reply With Quote

  7. #7
    Junior Member
    Join Date
    Apr 2005
    Posts
    8
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by alanschu:
    If you are trying it hit the side, make sure you are hitting it as close to 90 degrees into the side as possible. Shallow angle shots will just bounce off.

    Also, don't get "too" close to the ships. Torpedos have a minimum safe distance of 300 m before they arm themselves. They'll never explode before they travel 300 m. <HR></BLOCKQUOTE>

    So maybe I've been just too close to those ships. And I'm in a good position to take the shot.. I think that they aren't bouncing off.

    And answering to those other replies. I haven't been manually setting the torps. I think that U-Boat Captains rarely set the torps themselves. I think it was the Weapons Officers who set the torp settings. So now I'm just ORDERING the Weapons Officer to calculate the solutions and ORDERING him to fire. And then I can watch the fireworks.

    But yeah. Maybe I'm just too close to those ships. Thank you all
    Reply With Quote Reply With Quote

  8. #8
    Junior Member
    Join Date
    Apr 2005
    Posts
    8
    Oh and by the way, I use steam torps. And it's year 1939 :P
    Reply With Quote Reply With Quote

  9. #9
    Junior Member
    Join Date
    Apr 2005
    Posts
    8
    SH** I'm stupid. If I only would have looked this!
    Reply With Quote Reply With Quote

  10. #10
    I've found that T1s runnign on magnetic under the keel almost never duds. Even early in the war with a dud option turned on in realism.
    Violets are blue, roses are red, we're coming aboard, prepare to eat lead!
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •