Gurry686,

I've got an Nvidia 7950GT videocard and SCDA works just fine with an older driver, no corruption except for some missing background objects here and there in a few missions.

Make sure you turn off HDR in the Display Options menu by checking the customize box and then unchecking HDR in the next menu. Your settings ARE being kept even though the check mark returns to the next generation box whenever you go back into Display Options menu later on. Another bug I'm afraid.