Results 1 to 4 of 4

Thread: I don,t know what patches to install for IL-2 | Forums

  1. #1
    XyZspineZyX
    Guest
    Hello,
    Sorry for asking a question that was just previously answered but I don,t know what version I have.
    On opening screenshot there is no version listed.
    However, I bought a boxed version just last month. It was in one of the new small game boxes.
    I bought it from Best Buy in US.
    I looked at the patch list and could not understand which
    to install.
    The game runs fine .but I assume there are added features in the patches?
    Thanks very much
    Johnny
    jwalk2c
    Reply With Quote Reply With Quote

  2. #2
    XyZspineZyX
    Guest
    Hello,
    Sorry for asking a question that was just previously answered but I don,t know what version I have.
    On opening screenshot there is no version listed.
    However, I bought a boxed version just last month. It was in one of the new small game boxes.
    I bought it from Best Buy in US.
    I looked at the patch list and could not understand which
    to install.
    The game runs fine .but I assume there are added features in the patches?
    Thanks very much
    Johnny
    jwalk2c
    Reply With Quote Reply With Quote

  3. #3
    XyZspineZyX
    Guest
    If you need paches for IL-2 Sturmovik you have to install first 1.1a after that 1.2 and you all set.

    Have fun!
    Reply With Quote Reply With Quote

  4. #4
    XyZspineZyX
    Guest
    Thanks very much.
    Johnny
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •