Results 1 to 7 of 7

Thread: Settlers 7 - Play for 20 minutes. Screen Flicker, can't play. | Forums

  1. #1
    Okay, so my issue is that I can play for a solid 20 minutes or so, then my screen will flicker (black,white,black for about 10 seconds).

    The game will then come back up, and might run fine. If it does run fine, this will happen again in about 20 seconds to 1 minute.

    When it doesn't run fine, it will run at about 0.2 FPS permanently until the game is entirely restarted (exit to desktop). Once this happens even the main menu will be extremely slow as well and it's almost impossible to click any buttons.

    Restarting the client will correct the issue, but I honestly can't enjoy the game by restarting it every 10-20 minutes.

    I've tried a lot of different combinations of graphics settings and nothing has fixed the issue, just prolonged it from happening.

    My specs are:

    OS: Windows 7 Ultimate 32-bit
    Processor: AMD Athlon(tm) 64 X2 Dual Core 5200+ 2.60 GHz
    Memory (RAM): 2.00GB
    Graphics card: NVIDIA GeForce 8800 GTX (768 MB)


    Yes, I have updated my video drivers.
    Reply With Quote Reply With Quote

  2. #2
    I have the same issue. For so many people having a problem they should be looking into this ASAP and informing us. I may need to see if I can get my money back from Steam! smh
    Reply With Quote Reply With Quote

  3. #3
    Originally posted by SaladPlantation:
    Okay, so my issue is that I can play for a solid 20 minutes or so, then my screen will flicker (black,white,black for about 10 seconds).
    Your PC specs are fine, and you have already Updated your Video Card Drivers.

    But as a side note, have you first tried to Verify the Game Cache Files/GCF for Settlers 7, if you have you downloaded this Game from STEAM ?

    https://support.steampowered.c...p?ref=2037-QEUH-3335

    Have you also tried doing a Full re-install of the Game, if needed ? Does this Screen flickering occur only when you Play Settlers 7, or even with other Games ? Have you tried changing your Monitor, and the Cables ?

    Are there any Overheating signs on your Video Card, after your play any Game for 20 mins or more ?



    -----------------------------------------------------------
    Reply With Quote Reply With Quote

  4. #4
    I have tried verifying the game cashe files, and integrity of Settlers 7. This did not work.

    This is the only game that has this happen, it's not an issue with the monitor or cables either I've tried a different monitor.
    Reply With Quote Reply With Quote

  5. #5
    Originally posted by SaladPlantation:
    I have tried verifying the game cashe files, and integrity of Settlers 7. This did not work.

    This is the only game that has this happen, it's not an issue with the monitor or cables either I've tried a different monitor.
    Alright, so the Screen also flickers even when you change the Monitor's Refresh Rate/HZ, right ?

    If this happens only when you Play S7, then I don't think your Hardware or Software is an issue. Thanks for replying.



    ------------------------------------------------------------
    Reply With Quote Reply With Quote

  6. #6
    Junior Member
    Join Date
    Mar 2012
    Posts
    6
    Quote Originally Posted by KingDaniel0 View Post
    Alright, so the Screen also flickers even when you change the Monitor's Refresh Rate/HZ, right ?

    If this happens only when you Play S7, then I don't think your Hardware or Software is an issue. Thanks for replying.



    ------------------------------------------------------------

    I herd in another thread here that newer Nvidia Drivers (if you use a Nvidia card) fixes this problem that everyone using an Nvidia card has been having, can anyone confirm this?
    Reply With Quote Reply With Quote

  7. #7
    Settlers Moderator sings_in_tune's Avatar
    Join Date
    Mar 2011
    Location
    Southern Ontario, ...................... Canada
    Posts
    884
    There was an issue with Nvidia drivers that caused flickering.
    Original fix was to roll back to older driver but it has been fixed now with new driver - I have 295.73 and it works fine.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •