1. #1

    I don't understand Russian

    Hello,

    I have jumped on the opportunity to play it this weekend (technically it is still Thursday).

    But the game starts up in Russian and I do not understand it, I can pretend to read it but that is not helping.

    Is there a way to get it to English without going in-game?

    I look forward to an helpful reply regarding this topic.

    Greeting from me,

    Capt. SlowPoke
    Share this post

  2. #2

    It's in russian for me too

    Same here. It's stuck in Russian.

    I might want to buy this, but now, since it's loaded into my game list as something I can temporarily download - if I buy it, will it be stuck in Russian as well?

    I navigated my way down to in game options through watching you tube videos, all the way to language select, and indeed, the only two options are Russian and Chinese.

    I downloaded this from the "free weekend" option on Steam, while at my normal computer in the U.S.
    Share this post

  3. #3
    Twigs_Dee's Avatar Senior Member
    Join Date
    Jun 2013
    Location
    Alberta Canada
    Posts
    758
    Hopefully this helps, no clue.

    With Wildlands loaded, go into the menu (pause), options (4th from the bottom), than select language (2nd from the bottom) and change the bottom two to your language of choice.

    Ghost Wars, options (at the bottom) , than select language (2nd from the bottom) and change the bottom two to your language of choice.
     1 people found this helpful
    Share this post

  4. #4
    удачи
    Share this post

  5. #5
    Originally Posted by Twigs_Dee Go to original post
    Hopefully this helps, no clue.

    With Wildlands loaded, go into the menu (pause), options (4th from the bottom), than select language (2nd from the bottom) and change the bottom two to your language of choice.

    Ghost Wars, options (at the bottom) , than select language (2nd from the bottom) and change the bottom two to your language of choice.
    Yes, kinda.

    It helped me look for the correct location in where to search so I did not have to go trough all the options.

    In HACTPOÑKN go to the R3bIK and there the second option if you click to the left English will appear.

    So now it is in English for me Thank you Twigs_Dee
     1 people found this helpful
    Share this post

  6. #6
    Ubi-Iudex's Avatar Community Representative
    Join Date
    Nov 2016
    Posts
    1,974
    Appreciate the help on this, Twigs!

    This was an issue affecting Steam players, though has since been resolved. If anyone is continuing to experience this then please make sure to restart both your Steam and Uplay clients. Additionally, like Twigs suggested, you may also need to change your language settings to English in game.

    Additional details on this can be found in this thread HERE.
     1 people found this helpful
    Share this post