Results 1 to 4 of 4

Thread: [XB360]Trouble connecting to multiplayer Assassin's Creed 4 Xbox 360 | Forums

  1. #1
    Junior Member Mickford's Avatar
    Join Date
    May 2017

    Trouble connecting to multiplayer Assassin's Creed 4 Xbox 360

    In the past couple of weeks or so I have been having great difficulty in connecting to the multiplayer portion of Assassin's Creed 4 on my Xbox 360.
    It keeps putting me in Limited Mode and is telling me that the Ubisoft servers are unavailable. Sometimes I get lucky and it lets me connect (very rare), but will then kick me out after one match or sometimes sooner. I have even tried a different modem/router with the same results. Have not had any trouble connecting in the past with either modem.
    When I am connected my NAT settings are "Green" and have always been in the past.
    I was going to log this issue a couple of days ago, but when visiting the support website I noticed the bulletin across the top saying the servers were undergoing an emergency maintenance and would affect most games especially ones released prior to 2015. Is this maintenance still going on?
    Also I am located in Australia, not sure if that is relevant.
    I also have less than 20 friends on my Xbox Live friends list, not sure if this makes a difference either.
    I also currently have Gold membership with Xbox Live.
    I am only posting here as the support website won't let me submit a support case either by email or by chat.
    When attempting by email, it gives me the message "There was an error processing your request. Please try again later" and has been doing so for at least the last 12 hours.
    Please someone help.

  2. #2
    I'm in the same situation. When I try to login in Ubisoft servers or uplay link, I have an error with unavailable server.

    Please, Ubi, fix it.

  3. #3
    Same here... Green Nat for the minute that it works, internet connection is fine. It worked like two weeks ago too, so I don't know why it isn't now.

  4. #4

    green nat and cannot connect to sp and mp

    i have the same issue

    please fix ubisoft

    xbox 360 not the xbox one ver!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts