Thread: PCWin 10 creators update, game no longer works | Forums

  1. #1

    Win 10 creators update, game no longer works

    It just loads to a black screen, 10 seconds later "FC4 has stopped working"

    If i verify files it works that one time, the next time i go to play it "FC4 has stopped working", it does that over and over and.... it doesn't care if its in fullscreen or boarderless it will work the one time after varying files and that's it.

    Edit: now it just crashes, its stopped working completely.

    Edit: i fixed this, anyone else with this problem turn off 'Fast Sync' in the nVidia control panel.
    Share this post

  2. #2
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    1,885
    runs perfect here with the Windows creators update

    try shutting off the X box app if you have not done so .. ya gotta log in with a MS account to disable it

    also check for other apps that may cause an issue

    BACKROUND APPLICATIONS may also cause the game to not launch properly and you may need Exit out of them, or reconfigure them to work properly with Far Cry 4 known apps that can cause this are


    A. EVGA PRECISION


    B. MSI AFTERBURNER


    C. Riva Tuner Statistics Server


    D. DXtory


    E. Motionin Joy


    F. Anti Virus or Firewall software (AVG , Comodo, Bullguard etc.. <-- check settings)


    G. MSI true Color


    H. Evolve gameing client


    I. AMD Raptr \ AMD Gaming Evolved


    J. TeamViewer


    K. Overwolf


    L. Nvidia Geforce Experience Shadow Play as of Driver 361.75 in Jan 2016


    see this thred to possibly fix issues with afterburner causing black screen
    http://forums.ubi.com/showthread.php...rcry-4-Crash!?


    Please see this Page where it mentions Backround Applications and how you can try to see if one is possibly causing your issue with the game NOT starting or hanging
    https://support.ubi.com/en-US/FAQ/9/...0000000eio0CAA


    And if your running windows 10 make sure you launch both Steam and Uplay as Run As ADMINISTRATOR


    this game was shipped well before windows 10 did ...and yes you may need to take that extra step to run the game
    this games engine was created years before windows 10 shipped and that change may needed to allow the game to write any save files and or configuration files , windows 10 may handle file security \ permissions in a different way, then previous operating systems did.


    if you have a problem... try this


    right click on the games .exe file


    select properties


    select the compatability tab


    check the box that says run as Administrator


    set it to run in a windows 7 compatabilty mode


    you can also run the windows 10 compatablilty trouble shooter from that same window
    Share this post

  3. #3
    Thanks for the reply but unfortunately none of that works, i even went into the task manager and shut absolutely everything not needed to keep the compute alive down.

    I also set the FC4.exe to run as admin, to run in win 8 compatibility mode, set the useless bloat-ware UPlay to run as admin...... unistalled and reinstalled the whole thing 3 times in a row.... it simply refuses to work.

    This game is still being sold, for £25, that's nearly launch price, if they are still selling it at all let alone for premium sort of money they need to support it.

    Share this post

  4. #4
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    1,885
    dude did ya contact ubi support ?

    as i said it launches and runs perfect here with the Win 10 Pro Creators update

    did you update your drivers since you installed the MS update .. thats the first thing i did ..reinstalled all my drivers after i updated windows
    never trust MS driver updates with an OS upgrade

    If you continue to have issues PLEASE see the troubleshooting tips section here http://steamcommunity.com/app/298110...6486417358966/
    or




    open a support ticket or contact Ubi support for your region


    you can open a support ticket with Ubisoft Support at https://support.ubi.com


    or try to contact them via social media to see if they can update your ticket
    Facebook: https://www.facebook.com/UbisoftSupport
    Twitter: https://twitter.com/ubisoftsupport






    for Uplay Account Support you can try to contact them by Phone
    you can find phone number\ support options \ and support hours information @ https://support.ubi.com/en-GB/Contact#en-gb


    if you have an account problem call em on the Phone or use twitter or facebook are the fastest options or WEBCHAT


    here are the twitter and facebook links
    Facebook: https://www.facebook.com/UbisoftSupport
    Twitter: https://twitter.com/ubisoftsupport
    Share this post

  5. #5
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    1,885
    also btw the launch Price was much higher at launch .. it was $59.99 for the base game + $29.99 for the season pass or $89.99 for FarCry 4 gold when the game shipped
    i know as i bought the game, the night it shipped on Nov 18th 2014
    Share this post

  6. #6
    Steve64b's Avatar Member
    Join Date
    Jul 2016
    Location
    http://maps.farcry.eu/
    Posts
    140
    Works fine here too.

    Perhaps you could try resetting your game configuration to default by renaming the file at:
    %USERPROFILE%\Documents\My Games\Far Cry 4\{YOUR_UBI_HASH}\GamerProfile.xml
    Share this post

  7. #7
    Some other things that may help.
    Set steam to not download during game play
    especially if your games are on the same drive as the os.
    I would also check the drives for amy corrupted files or folders
    as the creators update has been known to cause this.
    Check when windows runs its updates, automatic maintenance schedule;
    the built in defragger can run for a long time.
    If you use a 3rd party antivirus-firewall make sure firewall is off for both private and public
    networks as well as windows defender app and browser settings.
    If you use a microsoft account set the store to update manually.
    Also check that the exe file was not set by the os to run in compatibility mode, etc.
    If you are using a nvidia gpu, check both nvidia control panel and geforce experiences
    settings.
    geforce experiences should be set to not optimize games automaticly, nvidia control panel needs
    to be set for the correct # of displays on the system, vr predetermined frame is set to -1 by default,
    change to app settings.
    Win10 pro curators ver 1703, amd 6x 2.8- 3.1 phenome 2, 8 gig ddr3, 2 2tb sata platers, 1 3tb sata plater, gtx 750 w 1g vram.
    The game runs well on this old clunker, but much fine tuning of the os was needed.
    Share this post

  8. #8
    I fixed this, anyone else with this problem turn off 'Fast Sync' in the nVidia control panel.
    Share this post

  9. #9
    Originally Posted by AbundantCores Go to original post
    I fixed this, anyone else with this problem turn off 'Fast Sync' in the nVidia control panel.
    Could you tell me how you do this?
    Share this post

  10. #10
    Originally Posted by kikindb Go to original post
    Could you tell me how you do this?
    Yes. tho if you don't know the chances you you didn't turn it on to start with, unless someone else did...

    Right click on Desktop and open nVidia control Panel.



    On the left click the link for "manage 3D settings, scroll down to "Vertical Sync" and select "use 3D application setting"

     1 people found this helpful
    Share this post