Thread: AC Revelation - graphic problem | Forums

  1. #11
    TRXTER20's Avatar Junior Member
    Join Date
    Sep 2014
    Location
    Saint-martin, French Carribean Island
    Posts
    3

    AC:R Graphic issue

    Hello,

    I have the same issue with Assassin's Creed: Revelation, i followed the instruction by deleting the Geforce Experience and 3D vision and it stll doesn't change. I also launched the game as administrator but in vain

    here's my computer's specs:
    Operating System: Windows 10 Famille 64-bit (10.0, Build 14393) (14393.rs1_release_sec.170327-1835)
    Language: French (Regional Setting: French)
    System Manufacturer: Micro-Star International Co., Ltd.
    System Model: GT72 2QD
    BIOS: E1781IMS.10H Ver: 00.00.00
    Processor: Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz (8 CPUs), ~2.6GHz
    Memory: 16384MB RAM
    Available OS Memory: 16338MB RAM
    Page File: 12766MB used, 19955MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 12
    DX Setup Parameters: Not found
    Card name: NVIDIA GeForce GTX 970M
    Manufacturer: NVIDIA
    Chip type: GeForce GTX 970M

    Please help.
    Share this post

  2. #12
    strigoi1958's Avatar Senior Member
    Join Date
    Oct 2010
    Location
    Norfolk UK
    Posts
    3,622
    You are using the dedicated graphics (gtx970M) not the intel graphics ? you can check using nvidia control panel https://youtu.be/PUBOYKICRso


    Did you delete the file systemdetection.dll ?
    Also go into uplay and disable the game overlay.
    And make sure you have vsync turned on.


    If that does not work you should try disabling a cpu core... to do that you need to run the game then ALT TTAB out and run task master then find ACRSP.Exe and set Affinity.


    Also, I am assuming you are French (or French speaking) so this might be easier for you
    http://forums-fr.ubi.com/forumdispla...sassin-s-Creed
    Share this post