Results 1 to 3 of 3

Thread: I finished all Uplay actions, but Uplay client and Ubisoft Club keep saying "0%" | Forums

  1. #1
    Junior Member L3tand3's Avatar
    Join Date
    Mar 2017
    Posts
    2

    Question I finished all Uplay actions, but Uplay client and Ubisoft Club keep saying "0%"

    So... I decided to finally make a full run and get all those Uplay rewards. I did it, full completed the game, so when I select "Uplay" from the main menu, it says "100%"

    See the pic: http://s102.photobucket.com/user/Let...gmccn.jpg.html

    But when I start the Uplay client from Wii U Wii U menu, I see this:

    http://s102.photobucket.com/user/Let...zec6c.jpg.html

    In other words, the game itself shows me that I did finish all Uplay actions, but Uplay client says that I did nothing. Same thing when I log in on Ubisoft Club from PC. I see Zombi U in my library, but when I select it, it says "no statistics for this game".

    I was logged in in the Uplay client before playing the game. There were no problems with my connection (I did play online, I saw the other players, I can log in with my account in Uplay client with no problems, etc). It wasn't a wrong account (I can see my avatar, nickname and my rewards in Assassin's Creed III). The game shows in my library. I had no problems with the Assassin's Creed III on this exact console and with this exact Uplay app. The game is patched, of course (console is connected to the internet).

    So... what's the big idea? I completed all Uplay actions, the game clearly shows it (see the photos), but Uplay refuses to give me my rewards and therefore I can't unlock the Uplay stuff. Any ideas how to fix that? I really want that unlockable content. Of course, I did write a letter to the support, but, of course, still no reply. Maybe it happened to somebody too? Maybe some players can help?

    Thanks.
     

  2. #2
    Junior Member Frishkii's Avatar
    Join Date
    May 2015
    Posts
    16
    Hi, this is very strange. Have you tried to check the unlockables in the game's menu? I mean, maybe the uPlay status bar needs time to update, but maybe your rewards are already in the game? Just go to extra content on the game's menu and you should find there the options to change the menu theme to the 80's style, watch the concept art video, cahnge the look/design of your cricket bat, and in multiplayer options menu you should see a new multiplayer mode.
     

  3. #3
    Junior Member L3tand3's Avatar
    Join Date
    Mar 2017
    Posts
    2
    Quote Originally Posted by Frishkii View Post
    Hi, this is very strange. Have you tried to check the unlockables in the game's menu? I mean, maybe the uPlay status bar needs time to update, but maybe your rewards are already in the game? Just go to extra content on the game's menu and you should find there the options to change the menu theme to the 80's style, watch the concept art video, cahnge the look/design of your cricket bat, and in multiplayer options menu you should see a new multiplayer mode.

    Thanks for reply! Unfortunately, it's not the case. All rewards are locked and I didn't even get the XP and Uplay Units to unlock them. It's just that - Uplay keeps saying that I didn't even play the game. The first action is very easy, so, I keep doing it, but still no reaction from Uplay. No XP, no Units, no rewards, no even statistics on the game (it still says that my last game played was Just Dance 2017 on different console). And since there's no way to get Units the other way, it's a big problem. Moreover, it sucks to lose the XP and badge you earned fair and square.
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •