Results 1 to 6 of 6

Thread: Please help | Forums

Map Editor | Far Cry 4 [UK]

Far Cry 4 | Kyrat Tuk Tuk Stories [EUROPE]

Far Cry® 4 Arena Master [UK]

CGI Launch Trailer | Far Cry 4 [PSN] [UK]

  1. #1
    Ever since I've downloaded Far Cry it's run like a turtle with an elephant on it's back. And it looks horrible!! I know that it's just a demo and it may not work well with certain system setups, but I'm sick of seeing everyone else's version looking and running better than mine with the same video card. I have a Radeon 9600 XT, P4 processor, 512 mb ram, 160 gig HD, and a 2.8 ghz processor. This isn't top of the line but it is good enough to play far cry because my friend accross the street has worse specs than me and his far cry works better than mine! For one, there are shadows that flicker on my hand(in the game) and the rocks flicker black too. And the characters do the same. I've tried low, medium, high, and highest(something like that)graphic settings and all the time it's the same. And the game gets choppy when there's more than 3 people on screen. What can I do to fix this?
    Reply With Quote Reply With Quote

  2. #2
    Ever since I've downloaded Far Cry it's run like a turtle with an elephant on it's back. And it looks horrible!! I know that it's just a demo and it may not work well with certain system setups, but I'm sick of seeing everyone else's version looking and running better than mine with the same video card. I have a Radeon 9600 XT, P4 processor, 512 mb ram, 160 gig HD, and a 2.8 ghz processor. This isn't top of the line but it is good enough to play far cry because my friend accross the street has worse specs than me and his far cry works better than mine! For one, there are shadows that flicker on my hand(in the game) and the rocks flicker black too. And the characters do the same. I've tried low, medium, high, and highest(something like that)graphic settings and all the time it's the same. And the game gets choppy when there's more than 3 people on screen. What can I do to fix this?
    Reply With Quote Reply With Quote

  3. #3
    Turn off AF on your graphics card to fix the shadow crap.

    Install new drivers.
    Reply With Quote Reply With Quote

  4. #4
    It allows me to turn it to 2X but not completely off. Where is it located in the control panel?
    Reply With Quote Reply With Quote

  5. #5
    nevermind
    Reply With Quote Reply With Quote

  6. #6
    Just set it to "Application Preference" to turn it off.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •