PDA

View Full Version : Uplay Overlay not working?



Soulofchaos123
05-27-2014, 12:57 PM
I am unable to play on private sessions by invites, me and a few buddies were going to play the game together, but I aint getting any invites or messages even though I do receive them and can send messages back to them back out to windows.

It seems it doesn't recogize Watch_Dogs, unable to access Uplay in game, online shop, or invite players, nothing happens.
- And I am pretty sure I have activated the overlay on Uplay settings.


This greatly confuses me.

x_xGodLikex_x
05-27-2014, 12:58 PM
Disable this useless ****, it causes game crashes.

Soulofchaos123
05-27-2014, 01:00 PM
Disable this useless ****, it causes game crashes.

I never experienced crashes though, and it is essentially the only way to play with friends.

MrWhitby
05-27-2014, 02:16 PM
Either way once you get the invite you won't be able to play with friends.

Just get Session no longer available...

Soulofchaos123
05-27-2014, 02:36 PM
Either way once you get the invite you won't be able to play with friends.

Just get Session no longer available...

Hmm.. I see.. However I prefer to have my overlay working, really. Since all of my friends basically has it working. awkwardly enough.

guest-Wg6QNi4k
05-27-2014, 09:17 PM
Hmm.. I see.. However I prefer to have my overlay working, really. Since all of my friends basically has it working. awkwardly enough.

Have you installed the game on a different directory than Uplay like me? (i have installed game on D drive while Uplay is on C drive)
I too am not able to invite my friends for a private session and can't access the ingame uplay shop. :(
Glad to know that i am not the only one having this problem.
Any help on this topic will be appreciated :)

P11120J
05-27-2014, 10:40 PM
I am also unable to access UPLAY overlay in game. There is a button "UPLAY" in the main menu of Watch_Dogs that appears to have no functionality for me (which I can only assume brings up the overlay). I checked my UPLAY settings and "Enable in-game overlay for supported games" and "Enable in game social notifications" is checked. Note I purchased the game through steam. Whenever a friend requests to party, no notification is given in-game, but a message in UPLAY's window does appear, but only a decline button is offered. Please help; I tried submitting a ticket on UPLAY.UBI.com except their servers won't even respond b/c of the release.

Thanks

guest-Wg6QNi4k
05-27-2014, 10:52 PM
I am also unable to access UPLAY overlay in game. There is a button "UPLAY" in the main menu of Watch_Dogs that appears to have no functionality for me (which I can only assume brings up the overlay). I checked my UPLAY settings and "Enable in-game overlay for supported games" and "Enable in game social notifications" is checked. Note I purchased the game through steam. Whenever a friend requests to party, no notification is given in-game, but a message in UPLAY's window does appear, but only a decline button is offered. Please help; I tried submitting a ticket on UPLAY.UBI.com except their servers won't even respond b/c of the release.

Thanks

I have finally found the solution. Its for both of you (OP and you). I too couldn't access the Uplay button in the game menu earlier, but now i can :D .
I couldn't click the invite friends earlier too. (Now i can also do this). Basically, the games need to be installed in the Uplay directory and folder. But i assume that all of us have installed Watch_Dogs onto a different directory instead of C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games.
The game needs to be installed in the above file path, but we can change the destination folder of installation. I had installed Watch_Dogs onto D:\Ubisoft\ .
What i did is, i went onto settings in Uplay(next to minimize button) and opened the settings. We have to click on the 'downloads' tab. After that, you'll see 'Default game installation location'. The default location will be the one i mentioned above (C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games), we have to change it to the directory where Watch_Dogs is installed. In my case, it was D:\Ubisoft, so i changed it to that path. Change the path to where Watch_Dogs has been installed. When you change it and start the game, you will be able to access Uplay from the main menu and online shop and other stuff.
Hope that this tutorial helps you both :D

guest-Wg6QNi4k
05-27-2014, 11:06 PM
Now that the servers are back online, i ain't able to click on uplay in the main menu :(
Sorry guys, but that trick doesn't work :'(

guest-Wg6QNi4k
05-28-2014, 12:15 AM
Ok so i have found a confirmed solution for all the problems. (uplay overlay not displayed, can't access uplay in the main menu, can't invite friends)
It seems that Uplay conflicts with additional softwares like FRAPS, i turned it off, overlay was working. When i turned FRAPS on again, overlay wasn't working. Overlay works without software like FRAPS. If you are using some 3rd party monitoring software, close it down. IT WILL WORK!!!!
FINALLY FOUND THE SOLUTION!!! :D
Though i dunno why FRAPS collides with Uplay XD

EkoCali
05-28-2014, 08:34 AM
Fraps for me works fine with the overlay but if you have NVidia's GeForce Experience open try closing that and relaunching your game as this is what caused problems for me.

haCid8510
05-28-2014, 12:24 PM
Hay guys, thank you for the info. Can confirm that closing down fraps and nvidia experience worked 100%. Can now use the uPlay overlay without any problems

MoogLe1337
05-29-2014, 05:08 AM
Hay guys, thank you for the info. Can confirm that closing down fraps and nvidia experience worked 100%. Can now use the uPlay overlay without any problems

Closing fraps worked for me, wierd thing is that the overlay worked fine with farcry 3 with fraps enabled.

this must be a bug in the game itself

hiredhelp
05-30-2014, 03:52 PM
Yeh just reading about that i not had fraps running but do use it. however i heard msi afterburner can make this happen i am closing that once ive RE downloaded this game. test it :( cheers buddy.

ZeCroWYuu
04-20-2015, 09:02 AM
If you don't have Fraps, it's probably cause your Steam, restart your computer and never open Steam, and Uplay's overlay will work !

xXdeath_skull10X
04-27-2017, 02:45 AM
I had this issue too, so I tried various of ways and then I gave up and tried to disable the FN lock and it worked because some system features are tied to the FN keys the FN lock toggles which one is being used(i,e I have f2 as volume down, so when I hit shift+f2 it's actually doing volume down). hope this is what the cause is for some of you.