PDA

View Full Version : [PC] Freezes for seconds at a time



SlasheeTheCow
05-27-2014, 10:45 AM
Fun game. Would be much more playable if it didn't freeze for seconds at a time. Usually runs alright for a little while, but after a little while it starts to freeze for a few seconds at a time (often while I'm driving). Makes it... frustrating, to say the least.

Sometimes, not only does the game freeze, it freezes my whole computer for that little while (can't switch programs on my G13, can't open Steam/Uplay overlay, can't even enable/disable numlock/capslock). Seems to get worse the longer I play (not that I timed it, but I wouldn't be surprised if it was getting up to 30 second freezes - often with less than 30 seconds between them - after a couple of hours).

I'm pretty sure it's not just that my hardware can't handle it either - when it freezes my GPU utilisation goes down to 0% (if it freezes long enough, they go down a power state), and CPU <5%.

I've tried:

Installing the latest Nvidia drivers (actually did that before I started playing)
Doing a clean reinstall of said Nvidia drivers
Setting all graphics options to lowest settings
Moving the game to my SSD (I thought my HDD might have been a bottleneck while it was streaming new areas, if it's helped, it hasn't helped by much)
Disabling SLI
Closing as many background processes as possible
Probably some other stuff I can't remember due to frustration


Important specs:
Windows 7 x64
i7 2600k @ Stock
8GB RAM
2x GeForce GTX 570

Ubi-MoshiMoshi
05-27-2014, 05:10 PM
Hi, please have a read here https://support.ubi.com/en-gb/FAQ.aspx?platformid=9&brandid=1979&productid=2841&faqid=kA030000000efNECAY

Please also keep an eye on this thread http://forums.ubi.com/showthread.php/882353-Watch_Dogs-Known-issues

If this persists please open a ticket with Technical Support, the link is in my signature.

the7thcolumn
02-20-2015, 08:01 PM
I would just like to say that I have fixed this issue after about 20 min of reading.

For those of you who use SSDs and have disabled page file then try turning it back on and set it to the default System Controlled page file.

I found that UbiSoft (and other companies but not to this extent) use the page file in order to improve caching.
With it OFF I cant play this game without stuttering on the following configs even on low:

ATI 5830
GTX 660 Ti
GTX 960

With it ON and set to System Allocates automatically the games run fine.

With even 6GB of ram installed and pagefile set to default I get zero stuttering. This occurred to me as I have it turned off on my media center but not on my desktop. When interchanging cards the issue was the same from ATI to Nvidia thus I deduce it is not the cards.

This also solved my issue in Facry 4 as well.

I tired also setting it between 1.5GB and 3.5GB but still found stuttering on occasion.

I hope this helps.

anukrom
12-04-2016, 11:38 PM
So, I got the same occurent freezez in Watch Dogs 2, and setting the disk that played the game to using virtual memory (from being "no paging file") seemed to relieve the problems! :) nice (win7)

PS. the paging file was set to automatic and no paging file was chosen on other disks than the OS disk, so I hadto invervene manually,

Cheers and thanks for the help, although being a generation after your issues :)