PDA

View Full Version : Bought might and magic on steam 50% off on steam...dosnt work...



Proteq401
04-15-2012, 12:23 AM
bought the deluxe for 27.99 yesterday April 13 and the cd key dosnt work....w t f...

Tobirb
04-15-2012, 01:32 AM
I just bought it aswell and I have the same problem :(

lunituni
04-15-2012, 06:07 AM
got the same problem -_-

darksage008
04-15-2012, 08:06 AM
same

Proteq401
04-15-2012, 04:41 PM
this is ridiculous does anyone kno if someone is doing anything about it? i mean 2 days? and still doesn't work? like come on?

SpectBR
04-15-2012, 06:13 PM
same with me

Naerdriel
04-15-2012, 07:13 PM
Same here. God****it.
Edit: I also became temporarily banned because I tried the two codes too many times. Awesome.

deface
04-15-2012, 08:50 PM
same, and temp banned yay.

deta257
04-15-2012, 08:52 PM
Same

rharding91
04-16-2012, 12:24 AM
Same here! Really looking forward to playing a game I paid for! WTF is up with this ubisoft launcher crap. Makes a game impossible to play just to keep people from pirating it.

Naerdriel
04-16-2012, 01:01 AM
I've written to Steam Support btw, so hopefully they'll fix this soon. And if the fault is not on their part, hopefully they'll contact these guys and have them fix it.

lamantjich
04-16-2012, 11:51 AM
I wrote to steamsupport aswell, at least it eases my mind to know that im not the only one having problems with this.

Evilmunky86
04-16-2012, 02:23 PM
I just had same problem bought on steam tried code failed then got banned ........ :(

Naerdriel
04-16-2012, 08:25 PM
Looks like it's working now. Decided to try the code again out of boredom and it let me through.

BadMotherF
04-17-2012, 05:07 PM
:mad::p:confused::(

Seamansage
04-25-2012, 04:53 PM
Здравствуйте! Объесните пожалуйста, когда покупаешь с лицензией набираешь код. А там сообщают, что код уже использован.?!

tump1969
04-25-2012, 10:03 PM
i bought this on impulse and i cant log in.keeps telling me invalid code then bans me.fix it ubisoft.

Ubi-Mush
04-26-2012, 10:57 AM
Hi guys, please contact Technical Support through the link in my signature.

alx286
05-26-2012, 11:59 AM
can not connect to the conflux, shows 'application error'. does anybody know what happen?