PDA

View Full Version : Game OK - but no audio



troyknight
05-16-2006, 12:57 PM
Received the game today, installed it, but I have no audio when I play the game, just on the splash screen and intro video (incidently this is the same prob I had with the demo but I figured there was a problem with the demo, not my computer setup!). I read the post by taytrefenwyd and made the changes. However this has not resolved the issue.

But here's something bizarre - if I start up Windows Media Player and select, say, an MP3 album to play, turn the music right down so I hear nothing, THEN start up HOMM V, the audio and sound effects are audible!!! How is that possible?

You might say, 'well, theres your problem solved', but it's inconceivable that every time I want to play HOMM V I have to first start WMP before I play the game. It also has a big effect on the speed the game plays at; in fact it slows it down a hell of a lot!

Tried contacting Ubi tech support but there is a problem with their site at the moment so I'm unable to get a message to them.

Has anyone experienced the same as me? Is there a way to rectify this in 'dxdiag'?

Incidently I have two soundcards - an EMU 0404 and a Realtec AC97, of which the latter has no speakers connected to it.

troyknight
05-16-2006, 12:57 PM
Received the game today, installed it, but I have no audio when I play the game, just on the splash screen and intro video (incidently this is the same prob I had with the demo but I figured there was a problem with the demo, not my computer setup!). I read the post by taytrefenwyd and made the changes. However this has not resolved the issue.

But here's something bizarre - if I start up Windows Media Player and select, say, an MP3 album to play, turn the music right down so I hear nothing, THEN start up HOMM V, the audio and sound effects are audible!!! How is that possible?

You might say, 'well, theres your problem solved', but it's inconceivable that every time I want to play HOMM V I have to first start WMP before I play the game. It also has a big effect on the speed the game plays at; in fact it slows it down a hell of a lot!

Tried contacting Ubi tech support but there is a problem with their site at the moment so I'm unable to get a message to them.

Has anyone experienced the same as me? Is there a way to rectify this in 'dxdiag'?

Incidently I have two soundcards - an EMU 0404 and a Realtec AC97, of which the latter has no speakers connected to it.

taytrefenwyd
05-16-2006, 01:40 PM
This is the solution that ubisoft gave me today which seemed to work on my system:

Go to start, then run.
Type dxdiag and press ok
disable "check for WHQL digital signatures"
Select the sound tab along the top
Move the hardware sound acceleration slider 1 notch to the left so that is in "standard acceleration"
Press Exit

Now run the game. If this doesn't work, try reducing the same slider 1 step to the left and try again.

troyknight
05-16-2006, 02:56 PM
Hi There,

Followed your instructions and this is what happened:

1) Lowered the acceleration to 'non' - sound played but was very jittery, so no go there;

2) Notched it up to 'basic' - no sound at all, even the intros never had any, where they had before, so no go there;

3) Went up to 'standard' - played intro sounds and music but no other in game audio, so again no go.

What's strange is that if I start up WMP and try to play the game, I still get no sound or music - WMP HAS to be playing a track BEFORE I start up HOMM V for me to get any audio at all. Incidently I just have to play one track, and even when thats finished, I suppose because WMP has been running in the background, the music and audio for HOMM V is still audible.

It's almost as if by playing a track in WMP it kinda 'opens up' access for the music to be heard in the game. I have never come across anything like this before; has anyone else?

Thanks for your advice taytrefenwyd, but Ubi's suggestion doesn't work for me. Does anyone else have any other ideas?