PDA

View Full Version : Good Processor, Low FPS



DracoX872
09-10-2010, 05:11 PM
Hey, I'm getting pretty low FPS on Assassin's Creed 2 while playing..

I was using FRAPS and it was displaying FPS of around ~20. Weird thing is, while playing, my computers only using around 30% of what its capable of. I uploaded a Youtube video of me playing.

YouTube Video (Click) (http://www.youtube.com/watch?v=k076QoJUGyE)
^System Specs in link too.. PS Run 480p

For those used to 40-60 FPS you should be able to see the difference. http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif


So is there any way to fully utilize my computer?

DracoX872
09-10-2010, 05:11 PM
Hey, I'm getting pretty low FPS on Assassin's Creed 2 while playing..

I was using FRAPS and it was displaying FPS of around ~20. Weird thing is, while playing, my computers only using around 30% of what its capable of. I uploaded a Youtube video of me playing.

YouTube Video (Click) (http://www.youtube.com/watch?v=k076QoJUGyE)
^System Specs in link too.. PS Run 480p

For those used to 40-60 FPS you should be able to see the difference. http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif


So is there any way to fully utilize my computer?

KingDaniel0
09-10-2010, 08:00 PM
----------------------------------------------------------------------------------------------------------

Actually your Laptop is creating the bottleneck here, because according to Official required Specs, it says, 'Laptop versions of Video cards may work but are NOT supported.' Some Games actually do not support the 'Mobile' version of Graphic cards. Read the Official required Specs here:

http://ubisoft.custhelp.com/cg...E!&p_li=&p_topview=1 (http://ubisoft.custhelp.com/cgi-bin/ubisoft.cfg/php/enduser/std_adp.php?p_faqid=13296&p_created=1267568669&p_sid=-FXq6Y7k&p_accessibility=0&p_redirect=&p_srch=1&p_lva=13228&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX 3Jvd19jbnQ9Niw2JnBfcHJvZHM9ODgsMjEwOCZwX2NhdHM9JnB fcHY9Mi4yMTA4JnBfY3Y9JnBfc2VhcmNoX3R5cGU9YW5zd2Vyc y5zZWFyY2hfbmwmcF9wYWdlPTE!&p_li=&p_topview=1)


Anyhow, Disable VSYNC as well as MULTISAMPLING, at the game's GRAPHICS Menu option. Try to turn these Options OFF while gaming, to get some FPS gain. Also turn down the SHADOW Quality.

TRY this: As you are having the Core i7 CPU, then make sure TURBO Mode is enabled in BIOS, so that the CPU can overclock by itself. For example, if you are using a Core i7 with 4 cores, and the game you are using uses only a Single core, the other three cores will turn off, reducing the heat produced by your processor, allowing the only running core to be automatically 'Overclocked' for higher performance. So give this a try, for higher single threaded performance. It increases Frequency of the CPU when not all cores are in use. This makes it more efficient.


Have you also first checked how many CPU cores have been 'utilized', after you start playing the Game ? You can also 'disable' some of the CPU cores, and then check for any in-game performance difference/FPS. You can do this via the TASK MANAGER. Have you monitored the 'CPU Usage' here, while the Game is running ?

After you have loaded the Game's Main Menu, Open Task Manager (CTRL+ALT+DEL/CTRL+SHIFT+ESC) and Click on the Processes Tab. On the Processes tab, at the bottom click on the 'Show processes from all users' Button. Now Right click the process i.e. AssassinsCreedIIGame.exe, and Click on the 'Set Affinity' option, and then look for the boxes labelled as CPU 0, CPU 1 etc. Just see how many CPU cores does the game fully utilize ? How many boxes are 'Checked' ?

You can also 'uncheck' the CPU 0, CPU 1 boxes here, if you want to play the game on Only 2 CPU cores, or even 1 Core. Not sure whether doing this will give any 'FPS gain' or not, but there is no harm in trying it. I don't have this Game, so I can't test this at my end.

So 'Uncheck' any 2 boxes labelled as CPU 0, CPU 1 etc., and click on the OK button. But first Launch the game and then press 'ALT-TAB' to go back to the desktop, and now open the Task Manager, and follow the above method. Press 'ALT-TAB' to go back to the game. But as you have the Core i7 CPU, so I think you need to 'Uncheck' any 6 boxes, to play the game on 2 CPU cores. Some Core i7 chips might display 8 boxes labelled as CPU 0, CPU 1, under the Task Manager.

//* NOTE. Some Core i7 CPU chips, Display 8 boxes instead of 4, under the processes Tab. These are actually Threads. Each of the four cores can process up to two threads simultaneously, so the processor appears to the OS as 'eight' CPUs. So that's why I told you to Unckeck 6 boxes. Or, you can turn 'Hyper-threading' to OFF in the BIOS, and uncheck only 2 boxes.


**Another method. Also Try this:: Insert the following command inside the Target line at the game's Shortcut TAB. Make a Shortcut of the game's .EXE and insert the following command (Right-click---->Go to properties---->Shortcut TAB):

C:\Windows\System32\cmd.exe /c start /HIGH /affinity 3 AssassinsCreedIIGame.exe

This will allow the game to run on High priority, and only on 2 CPU cores.

C:\Windows\System32\cmd.exe /c start /HIGH /affinity 1 AssassinsCreedIIGame.exe

This will allow the Game to run on High priority, and only on 1 CPU core.

There is another syntax which we can use: C:\Windows\System32\cmd.exe /c start “NameofExecutable.exe” /PRIORITY /AFFINITY # “Shortcut's path”. You can also Lower the process priority if needed. I don't suggest giving the Process, a very High Priority under Windows 7, because of better Memory Utilization. You can also use this tool for setting the CPU affinity/priority:

http://edgemeal.110mb.com/PriFinitty/index.htm


Close ALL background applications/AV scanners etc. while gaming, and if by any chance you have 'ASUS GamerOSD', and/or SmartDoctor installed, then kindly remove it. It has known to create a Lag with some of the PC titles.





----------------------------------------------------------------------------------------------------------------

DracoX872
09-11-2010, 03:05 PM
Hey, thanks. I did a bit of testing and found out Ubisoft is bs'ing us with the PC optimization thing.

I have a quad core i7 with hyper threading so I turned off all the "fake" cores. I just left CPU 0,1,2, and 3 on. Then I did a benchmark with fraps and lo and behold, the fps average went down by 1 fps.

They've gotta be joking me......

KingDaniel0
10-17-2010, 02:00 PM
-----------------------------------------------------------------------------------

Did you check whether the TURBO mode was enabled in BIOS ? You can also use this tool i.e. RivaTuner to get some FPS boost.

http://majorgeeks.com/Riva_Tuner_d737.html

e.g. Go to driver settings, and under the DirectDraw and Direct3D Settings, Click on 'Intellisample' tab and drag it to 'High Performance'. Uncheck the 'Blitting' tab option. But make sure the LMA tab is checked for maximum performance etc. I would also make sure the 'Enable user mipmaps' option is ticked (Adjust the Mipmap LOD Bias slider to some High value e.g. 3.0) .

Anyway, I just thought of pointing this out.
Bye.



------------------------------------------------------------------------------------

DracoX872
12-30-2010, 12:52 PM
Where are the driver settings? I'm so confused lol.