PDA

View Full Version : C: Stack Crash



dkohnen
09-17-2007, 09:40 PM
I get the following error even after I installed all new graphics card drivers for my 256MB nVidia GeForce 7900GS, reinstalled GRAW and the 1.00 to 1.04 patch. All other postings have the same title to the error but mine looks different with the C: Stack error.

Can anyone help?

***********************

Crash in application version: 30621.2989

Unhandled exception - access violation



C STACK:
??? (???) : ???
CT_OAL (???) : alcCreateContext
OpenAL32 (???) : alcCreateContext
??? (???) : ???
??? (???) : ???

Renderer: threaded
Physics : threaded

dkohnen
09-17-2007, 09:40 PM
I get the following error even after I installed all new graphics card drivers for my 256MB nVidia GeForce 7900GS, reinstalled GRAW and the 1.00 to 1.04 patch. All other postings have the same title to the error but mine looks different with the C: Stack error.

Can anyone help?

***********************

Crash in application version: 30621.2989

Unhandled exception - access violation



C STACK:
??? (???) : ???
CT_OAL (???) : alcCreateContext
OpenAL32 (???) : alcCreateContext
??? (???) : ???
??? (???) : ???

Renderer: threaded
Physics : threaded

HiImTed
09-17-2007, 09:45 PM
Yeah I've had the C stack too. Also have a 7900 GS. Did you actually get the game to work? What settings have helped?

unpredictabl3
09-17-2007, 09:59 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">CT_OAL </div></BLOCKQUOTE>
OpenAL/Generic hardware/CT_OAL/X-FI, audigy/Vista (http://www.nabble.com/Re:-Creative-Labs-and-OpenAL-p12301738.html)

If you have XP download OpenAL.ITs a free download. Once downloaded launch game and goto audio and do a auto detect. apply and play. Vista because of HAL cant use these features and must use generic hardware. even with a sound card that supports it.

ColinCJ
09-18-2007, 02:26 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by unpredictabl3:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">CT_OAL </div></BLOCKQUOTE>
OpenAL/Generic hardware/CT_OAL/X-FI, audigy/Vista (http://www.nabble.com/Re:-Creative-Labs-and-OpenAL-p12301738.html)

If you have XP download OpenAL.ITs a free download. Once downloaded launch game and goto audio and do a auto detect. apply and play. Vista because of HAL cant use these features and must use generic hardware. even with a sound card that supports it. </div></BLOCKQUOTE>

Yes thats a good idea I did that myself this week and it has improved my stabillity.

ColinCJ
09-18-2007, 02:36 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by dkohnen:
I get the following error even after I installed all new graphics card drivers for my 256MB nVidia GeForce 7900GS, reinstalled GRAW and the 1.00 to 1.04 patch. All other postings have the same title to the error but mine looks different with the C: Stack error.

Can anyone help?

***********************

Crash in application version: 30621.2989

Unhandled exception - access violation



C STACK:
??? (???) : ???
CT_OAL (???) : alcCreateContext
OpenAL32 (???) : alcCreateContext
??? (???) : ???
??? (???) : ???

Renderer: threaded
Physics : threaded </div></BLOCKQUOTE>
The settings you are running at need to be oposted with all your system info all of it hardware software etc.

dkohnen
09-18-2007, 07:27 PM
I haven't had the game working yet. I get this error while it is trying to start up so I haven't had a chance to change any settings yet.

dkohnen
09-18-2007, 07:50 PM
From the previous post's advice, I ran what I thought was the OpenAL exe file and then GRAW but the same error happened. The error comes up while the program loads and then freezes with..

***************
Crash in application version: 30621.2989
Unhandled exception - access violation

C STACK:
??? (???) : ???
CT_OAL (???) : alcCreateContext
OpenAL32 (???) : alcCreateContext
??? (???) : ???
??? (???) : ???
Renderer: threaded
Physics : threaded
************************************

I am running at the following settings:

From the GRAW Detection Program:

Windows XP Pro Service Pack 2, CPU freq 2394, Main Memory 2048 MB, Direct X Installed, version 9.0c, Video Card NVIDIA GeForce 7900 GS, Shader Model 3.000000, Graphics Driver Version 16218, Video Memory 256MB, Ageia Driver 70517, Sound Card - Creative Soundblaster X-FI,

From System Properties:
Intel Core2 6600 @ 2.4GHz, 2.39 GHz, 2.0 GB RAM, 169GB harddrive with 141 GB free.

What should I do here?

HiImTed
09-18-2007, 09:14 PM
please report back if you gaet a fix. I think we are having the exact same problem. Thanks-- Ted

ColinCJ
09-19-2007, 01:14 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">dkohnen </div></BLOCKQUOTE>
You need to completly uninstall your sound card drivers and reinstall the latest ones. your error indictes that is the cause.
Creative latest drivers include Open AL.

http://uk.europe.creative.com/support/downloads/downloa...ivertype=0&x=30&y=17 (http://uk.europe.creative.com/support/downloads/download.asp?MainCategory=1&nRegionFK=&nCountryFK=&nLanguageFK=&sOSName=Windows+XP&region=3&Product_Name=X-Fi+XtremeMusic&Product_ID=14066&modelnumber=&driverlang=1033&OS=10&drivertype=0&x=30&y=17)


This download contains an improved version of the drivers found on the Sound Blaster® X-Fi™ XtremeMusic, Platinum, Fatal1ty and Elite Pro installation CDs. It provides full OpenAL support for gamers. For more details, read the rest of this web release note.

This download includes Creative Audio Console, which enables you to configure the Sound Blaster X-Fi features and functions.
Added Features or Enhancements:

Supports OpenAL 1.1
Fixes:

Resolves the issue of the computer not responding when Cubase® interacts with X-Fi applications
Allows MidiSynth to synchronize properly with selected SoundFont® content
Resolves OpenAL issues
Requirements:

Microsoft Windows XP Professional x64 Edition or Windows XP Service Pack 2
Sound Blaster X-Fi XtremeMusic, Platinum, Fatal1ty and Elite Pro audio device
Notes:

Creative MediaSource DVD-Audio Player is unavailable for Windows XP Professional x64 Edition.

Buzzard73
10-16-2007, 04:33 PM
This is a sound driver issue.

I fixed mine by removing the creative driver and then using windows update to get the xfi driver from there.

worked fine after that.

werewolfking
10-21-2007, 05:01 PM
same thing i got the game to work by going to nvidia.com and updating my driver