PDA

View Full Version : Help please: Loading Problem



michaelt86
10-25-2008, 03:42 PM
I have successfully installed FarCry 2 on my PC.

I can load the game up to the main menu just fine. Once I have selected story mode, the difficulty, and my character the game begins to load. This is as far as I have gotten. The game hangs at the loading screen and does not go any further. I have tried to load story mode 4-5 times and everytime it freezes at the loading screen. The loading icon occasionally spins and I hear music. Once, I let it load for 15 minutes and came back to see occasional black squares pop on the loading background.

My system is:
Windows XP SP3 w/ current updates
Evga 8800GTS 320mb
AMD 3700+ socket 939
Asus a8n sli premium mobo
2 gigs 2*1gb ocz plat ddr800
600watt powersupply OCZ modxstream

I have not attempted to reinstall direct X or the game. I have the most up to day Nvidia gfx driver. Not sure what to do here. Game looks sweet just from browsing the menus.

I have attempted playing in safe mode as well and got the same hanging/freezing problem at the load screen. The benchmark also failed to load.

Mind you the game never freezes the music continues to play and the loading icon occasionally spins, it just goes no where. I actually get to the 3rd subtitle while loading where it's talking about the jackal and the fact that someone must want to take him down or something. I eventually just turn my PC off and on because I cant get to desktop once its loading. Control alt delete doesn't work very well. The task manager comes up ontop of the loading screen and then goes away after a few seconds. I cant even get to desktop with alt tab or the windows key.

tatko_nerez
11-05-2008, 12:24 PM
Hmm, same here. http://forums.ubi.com/groupee_common/emoticons/icon_confused.gif

myuniquenick
11-08-2008, 02:14 AM
Same problem for me too. Just noticed this after starting another thread.
http://forums.ubi.com/eve/forums/a/tpc/f/1821007696/m/3301041307

My system specs:

Processor: AMD Athlon 64 FX-55
Motherboard: Asus A8V-E Deluxe
Hard drive: Seagate Barracuda 7200.10 SATA 160GB
DVD drive: Sony DVD-ROM DDU1613-88
RAM: Corsair 2Gb
Video card: Asus EN7900GTX
Power supply: Corsair HX620W, Rev.B2W
Sound card: Creative Sound Blaster Audigy 2 ZS
Windows XP SP3

Can't spot the system similarity.