PDA

View Full Version : Game Save And Crashing Problems



columbo12345678
03-28-2005, 10:00 AM
I, like many others am having major problems with this game.

Most of the time it runs perfectly. no slowdowns, no problems of any kind at all.

I have a MONSTER pc and it runs ALL other modern games PERFECTLY. I have more than enough ram, cpu, etc. i have top of the range graphic and sound cards. all my drivers are up to date and working perfect, ALL of them. so please no noob flames about "you neeed a new pc". if you gonna start with that bs you can just **** off now, ok?

Here is my problem.

Career Saved Games do not function correctly. I have 2 recurring problems with these.

1. If i save my game or if it is automaticaly saved. I try to load a saved game, the game loads up, initializes and then after a time from 2-120 seconds of play it crashes to desktop, sometimes with error message sometimes without. This is happening to around %75 of all my saved games. If i start a new career, single mission or training everything works perfect. But from a saved game, nope, a minute play and then crash.

2. When my saved games do work, i find that i'm missing information. My crew loses their medals and qualifications, my boat loses parts i bought for it and my career logs lose information like tonnage sunk, etc.

There is something BIG TIME wrong with the way the saved games work. It is making this game unplayable for me. I am having to make triplicate backup saves every time i wish to save and then, considering the EXCESSIVE LOADING TIMES it is taking me up to 30 minutes to sort through them and find one that a, works and b, has my information intact.

ubi... you have really let me down with this pap.

i am really dissapointed because silent hunter is without a doubt the finest simulation game i have EVER seen or played. It is of such a grand scale, deep design and incredible levels of thought that i am simply stunned that such a major problem as "saved games don't work right" is going to put a spanner in the works for it.

stunned!

we have all dreamed of a game like this since the 80's for gods sake, now it is here and it doesn't work right!

and finally nobody even dare to say the words, drivers, upgrade or anything else ridiculous. this is a SOFTWARE problem. i can run everything from ultra high spec graphic demos, ultra high spec audio tools, highest spec games on the market, anything you care to mention. I have worked with computers since i was about 9 years old. i programmed full working games that were as good as company made games by the time i was 12. i know a pc inside out and back to front, i can build them, you name it, i know more about pcs than probably 99% of you guys.

I can also tell you that if you didn't work on this game you can't help me with my problem so don't embarres yourself by yelling "omgzorz u nub upgrade yo drivers! this game runs fine on my sh*tty onboard sound card!!!11"

just f*ck off.

i have no interest in STUPID, STUPID, STUPID "i left my game running for a week and it never crashed once" tests!!! i am telling you flat, this game does not save games correctly!

now i want a fix and i want it NOW!!!

get to work ubi! NOW!

thedeakin
03-28-2005, 10:06 AM
bravo
here here
this is some seritous bullsh!t to thinkt hat i paid $40 on something that dosent work

alk22
03-28-2005, 10:25 AM
I agree with you %100. I played for ages, quit, later that day i went and loaded up SHIII. Loaded my game, got to the initialized screen and crashed to desktop. I was pissed off. but im sure there already aware of this major flaw and working on a patch for us.

But if you look through the known issues thread there a quick fix for it,

columbo12345678
03-28-2005, 10:47 AM
there's a quick fix for it?

what is it?

i looked and saw the one about lowering sound accelration which doesn't work and another about disabling particles which doesn't work?

something i missed?

Pentallion
03-28-2005, 11:06 AM
I went back to my saved game and found out I was missing my whole crew! What is this? A spin off on an old Star Trek episode?

Ghworg66
03-28-2005, 12:31 PM
My problem i a bit the same.

After 12 or so patrols i got problems while loading an atomatic save.
The saves after mission and before mission always crashes me back to desktop.
After the first time i always save before going to base.
Loading a game takes a long time and this ways it takes twice as long
I don't have problem when i play the next mission right after the last one.
One more thing,maybe it has to do something with it.
Every time before i start a patrol i get the message:base was changed to willemshafen.
That message is showing up since my first transfer to brest (and later on two more bases)
Also when loading the departure point shows always:long and lat and distance = 0

But when i load my own saves everything is fine.
No missing crewmen or missing parts.
This should be high on ubi's to do list

columbo12345678
03-28-2005, 12:51 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Ghworg66:
This should be high on ubi's to do list <HR></BLOCKQUOTE>

Das_Boot_U96
03-28-2005, 08:20 PM
Hey Columbo, your lucky, I save during "career" mode", and when I go to play again, say the next day or whatever my saves have disappeared??

Have no problem on the single game modes, all saves intact, go figure.

The bottom line is this game was put out to market for profit, with a false promise of being "too good to be true", it's just that simple, "The End".

P.s. Major patches are needed now, but maybe that won't even save this sinking ship!

Very sad, since so many had waited so long in anticaption of this game.

return2sender
03-28-2005, 09:58 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Ghworg66:
This should be high on ubi's to do list <HR></BLOCKQUOTE>

x2

Xadavus
03-28-2005, 10:47 PM
Okay, I understand you know alot about the computers, and coding. I havn't come up to any problems yet (Patrol 21). Though one question did raise in my mind. Is it possible that somehow its linked with Windows Update?

I have seen some games be effected by windows update despite they have no relationship. Don't ask me why, but oddly few of my games had that effect.

Just a thought, humor and try. If it doesn't help oh well, back to flaming UBI.

On the other hand, we don't know how UBI write softwares, for all we know , they might have done mostly missions and didn't pay much attention to saved files. Ooops, hey many games come out with bugs, some are minor, other major, maybe this one is also minor, just makes a major effect... /shrug.

Anyways, happy hunting.

Xad

HKLE
03-28-2005, 11:05 PM
Hi folks

Unfortunately I had a similar experience. While playing a carrer mission (my first one) - I occasionally saved it. This worked very well. After 2 hours without saving, the game just quit on me when I pressed - I think it was - the crew management button and the last 2 hours of game were gone.

I did not - until now - have problems with saved games as such, but maybe just because my game time is so limited that I have not accumulated the necessary overall time yet.

What I noticed though, is that the game tends to become "slower" (i.e. picture show in heavy weather outside), when playing some time. This may be due to the known Windows problems with RAM management ... When saving and starting again, this problems seems to disappear.

AMD 2000+
Radeon 9700 pro
1GB RAM

zen2k
03-29-2005, 12:01 AM
I actually have the same problem as Das_Boot_U96. I saved my 'Career' and came back the next day and all my saves had disappeared!

I'm using the 1.1 patch. I was kinda hoping it was just something I did. I can't say reading that others are having the same problem makes me really wanna load it up again and start in on a new career knowing it won't be here tomorrow.

mike_w72
03-29-2005, 12:20 AM
Does anybody notice that we all have the same problems and just talk past eachother?

Is there a person from UBI monitoring this forum at all?

Any solutions for the save game problems?
anyone...Bueller...Bueller

AloNkap
03-29-2005, 02:34 AM
columbo honstly I dunno what you talking about..
I'm playing this game for a week, 13 patrols, with not even a single problem\crash..

Few bugs here and there but everything is working good, I have a kinda low machine to compare to what you describe your "MONSTER" machine and every other game work "PERFECTLY", no probs..

Try to uninstall and to defrag your hard-drive, try to disable window's update, screen saver, maybe your hard-drive is full with ad programs and spywares, try Ad-Aware..

Btw a note to yourself, a little modesty won't kill you http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

laurensxeon
03-29-2005, 02:42 AM
i got problems 2.

at first it seems like a great game. no crashes. and i've got none yet. save game's worked. but after a few days i want to load my save and it was gone !! http://forums.ubi.com/groupee_common/emoticons/icon_confused.gif oke **** happens. i started again a new career whit a VIIB sub. i've got 6 v&w destroyer and 1 merchant ship. i thougt pretty good. i save the game. want to load it a few hours later. and got a message the war ended. the date was 20 november 1939. the war did end on 1945 here in holland. and te reown point waren't negative.

well ubi soft u know what u have 2 do. and quick 2. i bought it for 45 " and the only thing i got is a half completed game ? http://forums.ubi.com/images/smilies/35.gif this realy make's me http://forums.ubi.com/images/smilies/cry.gif

Degamer
03-29-2005, 03:43 AM
Just as an investigatory question, of everyone who has had there saved games deleted, how many are running the Microsoft Anti-Spyware beta?

Pacificwing
03-29-2005, 05:59 AM
First of all, I'd like to say Cheers to Columbo for starting this thread and refusing to take any **** from the more fortunate individuals who've been able to run the game without issue.

I also experience this issue, and its extremely annoying for me because my lifestyle doesn't allow much time to play, and saves are critical for advancement. I'm only one my 3rd patrol, but I've played that same patrol several times due to the CTD save bug. I've decided to stop playing until the issue has been resolved. It should be noted that several of my friends who have voiced interest in the game have also been warned off until some of the issues are resolved.

For those individuals who say that the problem must exist in the users computer (due to spyware, viruses, obsolete drivers, etc), I realize that these are often the items that resolve many issues. Unfortunately, there comes a point where so many people are having the problem that it becomes apparent the issue must be within the software itself. We have computer technicians (including myself), computer programmers, regular users, and experienced hobbyists with completely different machines all experiencing the same problem. In many cases, reasonable troubleshooting measures have been taken.

I understand that not everyone is suffering from this issue, but please understand that this does not necessarily mean that the software is not flawed.

Currently the game is unplayable, as about 80% of saved games fail. I'm understanding of the fact that the game has bugs. What I can't tolerate is that no one has responded or acknowledged this issue. I find that lack of accountability on behalf of the development team appalling. Certainly this would not be tolerated in any other industry.

Columbo, don't let yourself be discouraged. This is very much an issue with the game. To those who are lucky enough to have evaded this problem, please be a little bit more sympathetic to those who are experiencing it. We HAVE updated our drivers, reinstalled the game, checked for viruses/adware, done windows update, defragged the hard drive, and in even some cases reinstalled windows. Reiterating these academic troubleshooting steps is not helping.

Cheers.
-PW

mike_w72
03-29-2005, 07:40 AM
agreed.

Look, a bug that effects save games is very disrupted and apparently widespread. I dont expect a patch today, but it would be nice to hear from Ubisoft that they are aware of the problem and are currently working on it.

No_312_RAF_Jura
03-29-2005, 08:05 AM
S! lads..
i have similiar problem.. everytime i load one of my save game (last one unfortuantely) i have 10-120 sec to play.. than the game crashes without single word :/ im realy sad about it..

anwittdc
03-29-2005, 08:23 AM
Hi Everyone...

I'm not sure this will help you, but it's worth a try... I was having the same problem as columbo12345678, where my save game would **** out after about two minutes- tried messing with sound, graphics, etc. no good.
So far now, I have been playing for five days with no CTD's since. ANd the only thing I've changed:

ONLY USE THE SAVE AND QUIT OPTION!!!

After I save, I just reload from the main menu and it's been working relatively well since (touch wood!). Try it out and see- if nothing else it could get you some kills until the patch arrives (hopefully soon).

Hope this helps....

anwittdc
1st Flotilla

Gardan23
03-29-2005, 09:14 AM
same problem here, when loading my savegame (career) after initialize crash to desktop. (single missions etc. works fine) till yesterday i could load my savegames.... (so the bug started at the 28th of March everywhere http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

tried everything from newest drivers over renaming config folder etc. would be nice to here something from ubi

columbo12345678
03-29-2005, 11:02 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by anwittdc:
Hi Everyone...

I'm not sure this will help you, but it's worth a try... I was having the same problem as columbo12345678, where my save game would **** out after about two minutes- tried messing with sound, graphics, etc. no good.
So far now, I have been playing for five days with no CTD's since. ANd the only thing I've changed:

ONLY USE THE SAVE AND QUIT OPTION!!!

After I save, I just reload from the main menu and it's been working relatively well since (touch wood!). Try it out and see- if nothing else it could get you some kills until the patch arrives (hopefully soon).

Hope this helps....

anwittdc
1st Flotilla <HR></BLOCKQUOTE>

thanks all for the support, the problem here is that we all agree this game is seriously good to play, as i said earlier. it is deeper and better thought out than any sub game ever! this is what makes these issues so irritating and such a huge problem. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

so yea, i have found that ignoring the auto saves and only using the in game saves and save + quit options is better, and to save and then use time compression to let some time pass, then save again helps. at least make sure you save LOTS so you won't lose your whole game but just maybe 1 patrol. at least the game is fun to play through a lost patrol! lol

and a note to AloNkap...

i'm not even going to dignify you witha response...

spyware? adware? defrag? jeez...

wtf do i sound like a complete noob then? thanks! lol

ctbrosky1974
03-29-2005, 07:03 PM
Hey All!!

This is a major F'n problem that needs fixed yesterday.

I've been playing for a week....had the black box with white circle bug. Finally fixed it. Today I've enjoyed the CTD bug everytime I've loaded a saved game and a round or torp makes contact with an enemy boat.

AB-SO-LUTE-LY F'N RIDICULOUS!!! So Pissed!! $40 for this POS program...

UBI - Wake the F up and put a functional program on the market. If you don't fix this sh#t game fast you had better start looking for management work at McDonald's in the EU because no one will purchase UBI software ever again. I'm certain I won't.

columbo12345678
03-29-2005, 09:22 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by ctbrosky1974:
Hey All!!

This is a major F'n problem that needs fixed yesterday.

I've been playing for a week....had the black box with white circle bug. Finally fixed it. Today I've enjoyed the CTD bug everytime I've loaded a saved game and a round or torp makes contact with an enemy boat.

AB-SO-LUTE-LY F'N RIDICULOUS!!! So Pissed!! $40 for this POS program...

_UBI_ - Wake the F up and put a functional program on the market. If you don't fix this sh#t game fast you had better start looking for management work at McDonald's in the EU because no one will purchase UBI software ever again. I'm certain I won't. <HR></BLOCKQUOTE>

lololololol

*hands ctbrosky the "quote of the year" award*

subgamer
03-29-2005, 09:56 PM
I am also having the same problem with the game unexpectedly crashing to Windows desktop! Only for me it happens for both new and saved missions. The game is barely usable in any capacity and my system exceeds the posted requirements on the UBI website. Incidentally, I have not been successful in opening a saved mission yet! I also do not have any problems with other demanding games I run routinely.

This game has terrific potential but needs a serious fix and soon! I do not need a $40 paper weight!!

Gardan23
03-31-2005, 01:48 AM
ubi, are you there ?

still cant load some saved career games without crashing to deskop

mbabbs
03-31-2005, 03:03 AM
Hi

I used to CTD and reboot regularly (sounds like a drug habit !), however since setting the hardware acceleration for the sound to off (and not just to standard) and never using the exit patrol option while anywhere but in port, I have not had any problems (I'm not sure this last point does anything but I have become paranoid).

I am not saying this is a solution that will work for you, but it definitely worked for me.

stoo1969
03-31-2005, 06:05 AM
Hi,
Ya i'm having more or less the same probs... http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif i find that (as already mentioned) 'save and exit' seems to keep the problem to a minimum but it still happens without warning, and there is nothing like a CTD for crushing your mood, when you are enjoying what is otherwise possibly one of the greatest games i have ever owned... very sad that an issue as serious as this one could have crept past the QA peeps....

Smidlee
03-31-2005, 09:13 AM
Well I on my 12 mission and having had no save problems. But this is before I lost my first career with this save game bug. I hope by reinstalling the whole game would solve this issue yet for what I've read others have had the same happen to them.The point is if you haven't lost your save yet then consider yourself lucky but you better backup you saved to desktop just in case. This bug is very real and seems to be random.

Biglou1981
03-31-2005, 11:00 AM
I am having crashes too. My computer handles all other games just fine. After about 45 mins I get a "Silent Service has encountered a problem and needs to close". Little pissed off here!

2.8 P4 800 fsb
1 gig ram
Nvidia 6800 GT @370

ctbrosky1974
04-04-2005, 10:07 AM
I agree with other people here. This is one of the most visually stunning games I've ever played. It also takes top prize for the buggiest release of all time. Quite a shame...

After numerous CTD's and thoughts of retaliation against UBI for causing a level of frustration never befoe achieved, I decided to perform an extensive search of this forum to find some sort of band-aid that would allow me to actually "play" the game.

Here's what I did to get SH3 to run error free all weekend long.

- Uninstalled SH3 (including Game Shadow & all folders)
- Updated drivers for EVERYTHING installed on my machine
- Defragged the HDD (both C & D partitions)
- Ran Ad-Aware, SpyBot, & Microsoft Anti-Spyware
- Turned off audio acceleration in DirectX
- Re-installed SH3 without Game Shadow
- Applied the SH3 DVD 1.1 patch
- Turned off all non-essential processes in Task Manager
- When saving, used only "Save & Exit" option. From the main menu, loaded the most recent save to continue playing

Forgive me if I'm wrong...but shouldn't a person be able to load and play a game without going through all the BS I described above? Am I asking too much? Why have games like Doom 3, Far Cry, and Half-Life 2 not caused these problems?? UBI, can you answer that??

My specs:
3.2 ghz processor
ATI 9800 Pro Video Card
Turtle Beach Santa Cruz sound card
Dolby 5.1 Surround Sound
1 GB RAM
400 GB HDD

technosub
04-04-2005, 08:33 PM
Same thing here.. my saved career patrols (mid patrol) are messed up.

If I try to load my game, my boat starts back at the dock as if my location was not saved, but my crew fatigue status has not changed.

A real pain since this pretty much means I cannot save the game at a contact and go to sleep. I can only play out entire patrols and only save at the beginning of the new day (so that I don't lose my location and fatigue). I haven't checked if I have lost actual crew members or equipment (shudder)..

What a ream.. I can't believe they released this with something as serious as save games messed up.

Ronin.nj
04-04-2005, 09:45 PM
sorry ubi`s but have to jump on the bandwagon,now my saves are okay if i return to base thats fine,but my problem is in mission saves,now im running windows Me, i havent upgraded anything or have windows update going i have just had an total reinstall my machine is not the best,but i have an 5700,256rm niv card that gets me thru,i cant complain about game play im amazed and thankfull that i can run the game.i do leave the music off,and have particle to aobut 70% since 1.1 i feel the graphics have improved with the uzo etc.i to tend to agree this is an bit annoying but i wont bother to give up,rubbish it or say its out early for the money.if this was so we would have no dynamic campaign.though with respect to the forum users some times it might reasure the masses by an simple acknowledge of the posts,by way of where this issue might have already been addressed,or of the intention to address it.in one respect people have shown in the preceding posts they are passionate about this product,
cheers and if you got any time on ya hands how about an destroyer command to match..http://forums.ubi.com/images/smilies/16x16_smiley-tongue.gif

CptnMiller
04-04-2005, 09:54 PM
Well i dont have the CTD issues some of u guys have, but i do have save game issues.

When i enter a mission and save the game, then return at a later time to pick up where i left off all my stats are blanked out. It reports my career start date as 0/0/0, all my tonage is set to 0 (even tho the captain's log reports i sank x amount of ships for x amount of tonnage), i get no medals, i get absolutely nothing as if i never even finished the patrol.

This is extremely frustrating. What do i have to do ?!?! finish an entire patrol w/o saving ?!?! Is the Save/exit patrol feature bugged ?!?! When my patrol is finished do i have to manually drive the boat back to port ?!?! seems to me when i use escape and finish patrol option im screwed http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

Hiriyu
04-04-2005, 10:35 PM
Hi fellas.

I guess I'm one of the "fortunate few" that has not seen this issue firsthand yet - knock on wood (I'm into my 13th Patrol in my first campaign now).

It sounds as if you guys might be on to some sort of common cause with regards to method of game saving, which might point to something identifiable and ultimately fixable in the game. I'm not implying that anyone is doing anything wrong procedurally, as this seems to be a very serious game-related issue that shouldn't be present at all.

I think that it's important that anyone else who has this problem post to this thread with specific information, such as how your saves are typically performed, and perhaps a list of your hardware, so that a common pattern of failure might be established, and perhaps a temporary workaround be found.

I have used only the default mission start and end autosaves, along with the 'save and quit' option from the menu. I run SHIII on a P4 2.6 with SIS chipset, ATI 9800PRO and 1 GB PC2700.

Good luck, and I hope for a speedy resolution!

CptnMiller
04-05-2005, 02:02 AM
Ok, just tested a patrol w/o saving once AND IT WORKED !!!. None of my patrol info (start date/ships sunk/tonage) got wiped out. Previously i had used the save option a few times and even the save/exit option all during the same patrol, seems from others posts that there is a problem with the SAVE option. I dont see complaints when people use the save/exit option so i might try that next patrol.

For the first time i recieved medals and even a qualification to give to the crew.

I would recommend NOT using the SAVE option during a patrol cause this seems to corupt the save file/entire patrol.

i have:
amd 1.67
512 mem
40gig HD (10 free)
FX5900 128mb

Johann_Witmer
04-05-2005, 03:45 AM
Well here is my original Rant

Check this out if you dare (http://forums.ubi.com/eve/forums?a=tpc&s=400102&f=857101043&m=9381071403)

My point is this.

We pay for the game....

It doesn't work.....

Company nor Devs say anything, They are all hiding under the desk.

People get p*ssed off
I'm P*ssed off

According to certain adverting law; if you buy something and it doesn't work it is NOT FIT FOR PURPOSE

Big problem here.

No Acknowledgement for UBI.COM

Why don't the peeps at UBI.com ask for our help in getting DATA (keyword UBI) so this can be fixed.

Of course it works, you have spyware !

My system is a perfectly running machine, I am a hardware Engineer with a MCSE so I do have a clue. There is no Spyware, system tweaked to the point that is runs like a Rolls Royce and not a volkswagen Beetle.

So UBI stop eating your cake and take some notice here. (NOT THAT YOU WILL) We want to help you to help us.

Hmm perhaps my Author Friend can help from the Times.

Now on with my problem. CTD on a regular basis and always happens in crew management screen. Hint. (There is always an enemy ship nearby.


My Rant

toogame
03-23-2006, 08:57 PM
http://forums.ubi.com/images/smilies/clap.gif

I CALL IT THE "TOOGAME SOLUTION"

OK for all you people with this F**KED UP problem, I have found a solution to this!
Crashing my saved game after loading, it just felt like yesterday I dived to 30m and a destroyer happened to depth charge a first lucky shot right on the u-boat right where the deck gun is "direct hit" INSTANT DEATH .....that mother F**KIN BI**H that one hit wonder!!

Anyway this game has a software problem, every last saved game is crupted, the game doesnt save properly as you might have guessed. I have deleted the last saved entry from saved game in career mode to where I have manualy saved (as I save and exit alot)so I will loose my last mission.

I then go into the saved file and open manual saved. this will open the "in mission" save.

You then press ESC and return to base. When your at base end the game close file and if you'd like reboot your pc (this might help unsure but it helped me)

When you get back into the game career go to CONTINUE CAREER this is the key, if you continue career it wont crash. What happend it went to patrol and I wasnt at base I was bearing 0 0 0 0 in the middle of the map. went back to base (which I got a message based change) then all ok. I didnt loose any data only the last patrol which I died anyway for that LUCKY F**KEN HIT UNBELEV F***IN ABLE

AND THATS IT,
http://forums.ubi.com/images/smilies/10.gif PASS IT ON

"TOOGAME SOLUTION"