PDA

View Full Version : A little help PLEASE!!!



andreyiu
01-24-2007, 12:20 PM
Maybe there is already a post with this subject,so if don't have time to give explanation,at least give the location of that post!!...my problem is: when i enter the game,i can't see the introduction movies..all that i can see it's a black screen with a big white "Z"!!! And when I equip a magical weapon,my screen looks like a chess table!!! what's the problem??

andreyiu
01-24-2007, 12:20 PM
Maybe there is already a post with this subject,so if don't have time to give explanation,at least give the location of that post!!...my problem is: when i enter the game,i can't see the introduction movies..all that i can see it's a black screen with a big white "Z"!!! And when I equip a magical weapon,my screen looks like a chess table!!! what's the problem??

Oakwarrior
01-24-2007, 01:21 PM
What's your PC's specs?

Quenaelin
01-24-2007, 03:41 PM
Looks like you don't have DX9 combatible graphics card.

OddBa1l
01-24-2007, 05:38 PM
The chequerboard and "Z" indicate a missing texture and missing sprites/decals (for particle effects). I think it also displays the Z for missing/corrupt movies too. Try reinstalling the game. If that doesn't work, install the Steam version. After installation, right click on the game in your Steam games list, choose "properties" then "local files". Choose "validate" from the list. This will check your installation, and download any missing/corrupt data. Hope that helps, and good luck.

Quenaelin
01-25-2007, 02:16 AM
No need for reinstalling, you just don't have DX9 compatible graphics card, buy new card and you are ready to play.

Oakwarrior
01-25-2007, 07:38 AM
You don't know that yet.

Quenaelin
01-25-2007, 07:51 AM
No, but nothing to do with reinstalling that is for sure, becouse game loads only graphics don't show. This game needs DX90 shaders to display graphics properly.

andreyiu
01-25-2007, 08:57 AM
My video card is nVidia GeForce Fx5200! It's a bit older,but until now i didn't had any problem with it!! And it's a compatible DX9 video card (most of the games requiers that,and all of them works on my video card...except Dark Messiah)!! ...and I have the latest video driver!!

ForgeBimbo
01-25-2007, 09:49 AM
Dark Messiah seems to be notorious for having mislead the consumer about 'compatable equipment'. You should be able to add "-dxlevel 81" to your launch shortcut and hopefully resolve 'that' issue...

Oakwarrior
01-25-2007, 10:23 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">No, but nothing to do with reinstalling that is for sure, becouse game loads only graphics don't show. This game needs DX90 shaders to display graphics properly. </div></BLOCKQUOTE>

The game loads and the graphics may NOT load. But IIRC that bug was ironed out anyways http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

And yes, do try the -dxlevel81 thingie, it will most probably help, if not, a reinstall is a must.

Mana_SG
01-25-2007, 11:55 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by andreyiu:
My video card is nVidia GeForce Fx5200! It's a bit older,but until now i didn't had any problem with it!! And it's a compatible DX9 video card (most of the games requiers that,and all of them works on my video card...except Dark Messiah)!! ...and I have the latest video driver!! </div></BLOCKQUOTE>
It should default to DX 8 as the first geforce DX 9 cards are not able to handle source at level 9.

Also make sure to try mat_picmic 1-4

mat_picmip 4 should fix mostly anything but send you back to the old days of Quake :P

ViciousGuy
01-25-2007, 04:24 PM
If that above didn't work you could try this:
I found this a while ago as a link in the Tech Help forum. However, I fail to find it.

You could skip the cutscenes (press [esc]) and then watch the scenes while DM isn't running.
It is not what you have been looking for, but at least you would be able to watch the cuscenes at all.

-Download the Binkplayer here (http://www.radgametools.com/).

-copy the binkplay.exe into [wherever your ubisoft folder is]\ubisoft\Dark Messiah of Might and Magic\mm\media

-then create batchfiles (see at the bottom) for every video one and write into each:

binkplay.exe [the name of the cutscene] /t0X

X is a number between 1 and 6
Each number is for the language that should be spoken in the cutscene:

1 = english
2 = french
3 = german
4 = italian
5 = don't know the language. Just try it and tell me what it is.
6 = could be spanish

For an example:
If you would want to see the cutscene where Sareth meets Phenrig who sends him to Stonehelm and you want them him to speak english the code would be:

binkplay.exe cutscene_phenrig_briefing.bik /t01


How to create batch files:
There are two ways to do so.

1st:You do it with the cmd (I won't explain for the second option is much easier)

2nd:You create a new .txt and rename it so it says ".bat" at the end (it could also be .cmd). Just make sure it doesn't say ".bat.txt" for that wouldn't help anyhow. Now click with your right mouse button onto the .bat and select "edit". There you can write down your code.
You have to make a new .bat file for every video you want to see.

To run the movie, simply click the .bat twice and it should run. If you don't care about the sound, you could skip the batch files and just click the .bik files.

Can't help you with the magic weapons.

Ys, VG.

OddBa1l
01-26-2007, 08:26 PM
The purple and black chequer pattern IS a missing texture, not a display error. It's the standard Source "error" texture, used when a texture is missing or broken. If that's what you're seeing when you're screen goes "like a chess table", then a validated install may help.

andreyiu
01-27-2007, 06:46 AM
Thank guys!! I appreciate your efforts!!! I O U

njnyposp
01-27-2007, 01:37 PM
Make sure you have both patches 1.01 & 1.02 and if you add the following command to the launch properties the checkerboard effect will go away
-dxlevel 81 type it exactly as it appears. dash dxlevel space 81. If your adding it to a launch string in the properties of the launch icon it should look something like this: ....mm.exe -dxlevel 81 IF ur using steam right click on the game and go to launch properties and type -dxlevel 81 and you should be able to play without that annoying checkerboard.