PDA

View Full Version : Serious technical problems (lag on high end system)



AFOTAI
09-28-2007, 05:54 PM
Bought settlers, presuming it would run at least flawless on medium setting, but it didn't! Not even on lowest resolution with everything turned off/ or on minimum.

I tried almost everything, changing the compatibility mode, running as admin, disabling Windows Vista effects while the program runs...

I'm running Windows Vista Business 32bit.
Core 2 Duo 2.20 Ghz
2Gb of RAM (667mhz)
Ati Mobility Radeon HD 2600 265mb dedicated mem and 512 Hyper mem.

Anyone else getting such errors or someone who found a fix?

AFOTAI
09-28-2007, 05:54 PM
Bought settlers, presuming it would run at least flawless on medium setting, but it didn't! Not even on lowest resolution with everything turned off/ or on minimum.

I tried almost everything, changing the compatibility mode, running as admin, disabling Windows Vista effects while the program runs...

I'm running Windows Vista Business 32bit.
Core 2 Duo 2.20 Ghz
2Gb of RAM (667mhz)
Ati Mobility Radeon HD 2600 265mb dedicated mem and 512 Hyper mem.

Anyone else getting such errors or someone who found a fix?

jonnypho
09-28-2007, 11:02 PM
I'm in the same boat.

Ran the demo and even with everything turned down as low as it can go and in 800x600 the scrolling is terrible.

Seems so laggy and slow.

AMD X2 3800
2 gig ram
ATI 1950XT 256Meg

Any ideas?

citybuilder
09-29-2007, 12:18 AM
To the OP: Is that a laptop? Isn't the Mobility line of of video for laptops or do they make them for desktops too?

AugustM
09-29-2007, 12:05 PM
I have the same problem; lag, very slow on High Graphical Quality, and it does not display the fog correctly: it flickers a lot and so does some trees and rock formations.

Can anyone please help me (us)?

Windows Vista Hom Premium X64
Intel Core 2 Duo E6700 2.66Ghz
4.5 Gb RAM 677Mhz
Ati Radeon HD 2900XT 1Gb in crossfire.

AFOTAI
09-29-2007, 06:05 PM
But do you also have the lag when you set everything on the lowest with your machine? Since I still have it, and we got equal specs :-/

XxMastrAssassinx
09-29-2007, 07:50 PM
I had the same problem with my laptop. I read somewhere that if you go to my documents (or just documents on vista) and go to settlers/config/options and change the refresh rate to whatever your monitors refresh rate is. It seemed to work better for me.

AugustM
09-29-2007, 11:29 PM
The flickering of certain objects is extremely irritating, but when i take screencaps nothing seeems wrong. It's the fog that makes objects flicker and even the fog itself flickers constantly.

Does anyone have any ideas for a fix?

kenzo777
09-30-2007, 01:07 AM
I don't have any problems with flickering
Using Nvidia Geforce 7600

But it's damn slow...Even on the lowest settings

Intel Duo Core 2.16
Ram 512(that could be a problem)
Going to buy today 1 GBram

Will let you know how it is going.

Azazell83
09-30-2007, 02:37 AM
You must change Detale Terrain (options graphics) - on LOW. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Sorry my bad english.

--
I have Athlon 64 3000, 2gb ram, gf 7600 and
Detale Terraing in LOW, rest settings in MAX !! include AAx6 and AFx16.. and I have 20-50FPS http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Villemo79
09-30-2007, 02:43 AM
I have the same problem.. it would be nice if it could be fixed. http://forums.ubi.com/images/smilies/16x16_smiley-sad.gif

AFOTAI
09-30-2007, 04:45 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Azazell83:
You must change Detale Terrain (options graphics) - on LOW. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Sorry my bad english.

--
I have Athlon 64 3000, 2gb ram, gf 7600 and
Detale Terraing in LOW, rest settings in MAX !! include AAx6 and AFx16.. and I have 20-50FPS http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif </div></BLOCKQUOTE>

Weird, since i got practically the same setup (but then on a laptop and Vista) and everything still lags when I place everything on Low / and disable shaders. Its ... horrible

Azazell83
09-30-2007, 09:24 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by AFOTAI:

Weird, since i got practically the same setup (but then on a laptop and Vista) and everything still lags when I place everything on Low / and disable shaders. Its ... horrible </div></BLOCKQUOTE>

hmm I have Windows XP SP2.. Maybe you system Vista or Laptop is cause problem?

How to many FPS of the game?

AFOTAI
09-30-2007, 04:06 PM
Yea, I run Windows Vista Business (32bit)

I dont' know how i can let the fps show up, but i think its near 5-10

Gundwane1978
09-30-2007, 04:32 PM
Yeaa I and my friend have same problem too..My system fx-60 x1800xt vista32 my friend's systems q6600 x1950pro and xp32..??? Is there anyone who apply the 1.1 patch..Is there any correction..??

Uniquemind
09-30-2007, 04:41 PM
Got the same but only so far in that the scrolling is jerky, and I am running on this:

Windows Vista 64-Bit
Intel Core 2 Duo 6600 @2.40GHz
2046MB DDR2
GeForce 8800 GTX 768MB

The rest of the game so far is fine, but in a game like this you need the scrolling to be smooth, and this is what disappoints me, great game, just would like it to be nice and smooth.

PWH
09-30-2007, 04:49 PM
Have you ajusted in game scrolling speed, menu optoins game?
Theirs two one at start up, one in game, same with video settings.

You could also mess with the config file.
C:\Documents and Settings\PWH\My Documents\THE SETTLERS - Rise of an Empire\Config

[Display]
AnimationQuality=2
Anisotropy=4
AspectRatio=Default
Brightness=50
Clutter=4
Contrast=24
EdgeSmoothing=2
MultiSampling=1
Occlusion=2
OrnamentalItems=1
Reflections=2
RefreshRate=60
ResolutionDepth=32
ResolutionHeight=768
ResolutionWidth=1360
Shader=1
ShadowMapSize=2
Terrain=2
TextureResolution=3
Windowed=0

[Game]
BorderScrolling=3.000000
ScrollSpeed=6000.000000
ZoomSpeed=8.000000

[Profile]
Current=PWH

[Video]
Subtitles=0

AFOTAI
10-01-2007, 03:21 AM
Lowering the refreshrate gave the performance a little boost (yes, lowering)

But it still doesn't run as it should be http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

XyZspineZyX
01-10-2008, 04:24 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by PWH:
BorderScrolling=3.000000
ScrollSpeed=6000.000000
ZoomSpeed=8.000000
</div></BLOCKQUOTE>

Changing ScrollSpeed to 8000.000000 improves scrolling a lot. Thanks for the tip m8!