PDA

View Full Version : Error initializing Graphic Interface



DI_33
07-30-2007, 03:26 PM
When I start Settlers 4 I get the error:
Software 3D, Error initializing Graphic Interface
Software 3D, Fehler beim starten der Grafik ausgabe

I have searched the internet for a solution and I have tried many things, but the problem keeps coming back....

I have Windows XP and a NVIDIA GEFORCE FX 5600-grafic card.
Deinstalling S4 and installing it again, installing the last patch (1516a), installing a new driver from NVIDIA, directX reinstalled...
Nothing seems to work....

I had the problem before (oct 2006), but we managed to solve it, but now the problem emerges again and we can't find the solution for the problem http://forums.ubi.com/groupee_common/emoticons/icon_confused.gif

Can someone help me ? http://forums.ubi.com/images/smilies/sadeyes.gif
Thanks for your help !

jordanpetch
02-14-2008, 03:30 AM
I have this problem too please somebody help!

Im on a laptop running DirectX 9, windows XP, Geforce 8600!

I really wanna play this game http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

nusehtnere
05-03-2008, 03:20 PM
same problem here!
WinXP, SP2, directX 9.0c, settlers 4 v. 1516a and the newest nvidia drivers for nvidia 8600GT
i also tried compatibility-mode for win95, win 2000, ...

and this is the error message i get
http://img363.imageshack.us/img363/4263/errorvq7.jpg

pls help http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

Wh1teLeopard
05-19-2008, 11:53 AM
I had this same problem, and found this thread through a google search.

I fixed it in the end by simply updating my graphic card drivers. I found them in the device manager and just clicked update driver.

Hope this helps some people out.

Schaza
12-14-2008, 03:08 PM
same problem here, and urgently help needed... i'm using:

AMD64X2 DCP 5200+, ATI 3D RAGE II+DVD, Realtek soundcard,
Win2K, SP4, directX 9.0c, settlers 4 v. 1516a

BTOG46
12-14-2008, 04:08 PM
I think your problem is probably the very old video card you have.
How come you're running such an old card on an AMD 64X2 system?
If my memory serves me right, that card was only a 2mb, Direct X 5 card, and the minimum for S4 is a 4mb Directx 7, while the recommended is a 32mb card.
I think you should fit a much newer card, as it was made back in the early days of DVD's and was designed for playback support rather than playing games.

Schaza
12-15-2008, 04:29 AM
That was it. Thanks BTO. :mrgreen: I thinked that may be a problem.

Reason for that very old card is just this. I have 4 different newer cards but none of them doesn't fit into board, except this one. There isn't any slot on board where i can put my old faithful favourite card, Matrox 550!http://forums.ubi.com/groupee_common/emoticons/icon_frown.gifhttp://forums.ubi.com/groupee_common/emoticons/icon_frown.gifhttp://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

BTOG46
12-15-2008, 09:35 AM
Your computer, given that it's an AMD 64X2 system, will have a PCI-Express x 16 video card slot, there are plenty of cards available to fit from as little as 20 that will happily play Settlers IV, as well as allowing you to play much newer games.

If you want to see what's available, here's a link to some , purely for reference, as I don't know whether you like to buy online, or at your local computer store, but it gives an idea of the price, and power range of what will fit your computer:

Tiger Direct PCI-Express video cards (http://www.tigerdirect.com/applications/category/category_slc.asp?CatId=1558&name=PCI-Express-Video-Cards&)


if your main aim is to play Settlers IV, avoid the 8000 series of the Nvidia GeForce cards, as they give a "black box" screen bug in the game, and the only way to avoid the problem with one of those, is to run a virtual PC on your computer, you may have noticed the long thread about it. http://forums.ubi.com/images/smilies/compsmash.gif

ChiefWhosm
12-15-2008, 01:14 PM
People have the 9 series as well with the blackbox issues.

Dunno about the 20x series from nvidia, but I reckon its their drivers causing it.

Schaza
12-15-2008, 05:46 PM
I'm so EXTREMELY ****ed off... i built a whole computer to get S4 work... 8 hours to get all hardware, software, all drivers, all... 8 hours, 14 beers, plenty of tobacco...

There is some weird VB-609 motherboard (HP Vectra, because that was only which had a basic AGP-slot) with Matrox 550 graphig card with 32MB mem, and all other stuff...

I INSTALLED IT EASILY TO THAT CONFIGURATION!! That was very very nice after these few days. =)

I PLAYED S4 ABOUT 20 FU**ING SECOND, AND THEN, BSOD (blue screen of death)

Win98SE said that there is illegal operation with Kernel, and that was it...

Error was something "in address 0D..." blah blah blah...

Give me something... something... please...

ChiefWhosm
12-16-2008, 09:41 AM
Sounds like 98SE is a corrupt installation, if its comaplining about kernel errors, also it wouldn't surprise me if its an issue with matrox card drivers. See if you can find any newer drivers for it, or try linux and wine http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

pennyuk
12-16-2008, 10:03 AM
Wasnt 98SE corrupt anyway Chief http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif I remember at the start of S4 getting lots of BSOD,had a couple with Vista and thought here we go again,back to the Settlers days.

Schaza
12-16-2008, 12:54 PM
Originally posted by ChiefWhosm:
Sounds like 98SE is a corrupt installation, if its comaplining about kernel errors, also it wouldn't surprise me if its an issue with matrox card drivers. See if you can find any newer drivers for it, or try linux and wine http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif
There is two things in world which i cannot understand, Linux and wine. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

I don't have any working Windows disks now. I have try to found one dvd where i have 95/98/2K/XP.