PDA

View Full Version : X52 Problem...



conuk
02-09-2005, 03:44 PM
For some reason My X52 has stopped working properly.

The Profile is selected via tray icon before LOMAC starts.

The axes work ok - but none of the buttons work.

ive selected X52 in the options menu in LOCK - and cleared the buttons.....

when i goto main menu and then back again keyboard is selected ?? huh???

Whats up ?

konkussion
02-09-2005, 04:29 PM
by default the lock on input menu will always come up keyboard first. If your stick isn't working- de- activate your profile. right click on icon, go to control panel- check the testing. if the buttons respond, re activate the profile and try it again. If it still won't work- this is where I have to get off, as I don't have a 52, I have a 45. You can open the profile back up, and ensure that everything is as you left it. try re-writing a couple of commands- see that they map correctly.

I mean- If the axes you set up within lock on work, but the buttons don't- there's something up with the SST, the profile, or the stick itself. If your profile appears to be ok- make a backup copy and reinstall- delete the leftover folder, too.

If you put the profile in the new install with no joy... I would test someone else's profile to see what happens.

Fireant1926
02-10-2005, 09:02 AM
I have my buttons dissapear from time to time on my X52 .. I have found I have to actually unplug the joystick from the USB port for it to come back to life ... just switching off the power on my machine does not depower the joystick for some reason .. the blue lights still stay on after the computer has switched off .. must be something to do with my powersupply or something .. I dunno .. weird

conuk
02-10-2005, 09:13 AM
I WAS right to clear all the `button` options in the Lomac settings wasn`t I ? http://forums.ubi.com/groupee_common/emoticons/icon_confused.gif

Flight Simulator works ok - the control panel isnt a problem.

If I manually select a key in Lomac -- say flaps.. clear .. then change ... press a button on stick ... it then works in game.

Surely dont have to do that for all again ?

SoFew
02-11-2005, 01:07 PM
Hi all,
I have been having problems with my X52 also. I cannot get a missile to fire when I have a lock on a bogey, I only fire the cannon! I select a profile from the taskbar as per the documentation, but still no luck. I have also cleared all the keys from the options screen for the X52 and re-mapped all the axis/sliders etc.

Any suggestions? http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

konkussion
02-12-2005, 08:48 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by conuk:
I WAS right to clear all the `button` options in the Lomac settings wasn`t I ? http://forums.ubi.com/groupee_common/emoticons/icon_confused.gif

<HR></BLOCKQUOTE>

AFTER selecting your stick in the device list- yes. CLear all default buttons assigned by lock on to your stick. Use the lock on mappings for your AXES only. Otherwise- use your profile.

Miki40
02-15-2005, 07:04 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by Fireant1926:
I have my buttons dissapear from time to time on my X52 .. I have found I have to actually unplug the joystick from the USB port for it to come back to life ... just switching off the power on my machine does not depower the joystick for some reason .. the blue lights still stay on after the computer has switched off .. must be something to do with my powersupply or something .. I dunno .. weird <HR></BLOCKQUOTE>

I have sorted this issue installing a PCI USB card and disabling USB support in BIOS for my mobo.
It is a specific issue especially with Nforce boards.

johnraines
02-19-2005, 04:21 PM
I had the same problem and found that LOMAC uses "Enter" and "Spacebar" to fire the missles and cannon. So, I had to reprogram button two (2) on the X52 to fire missles and the trigger for the cannon as it was anyway.

Hope this helps.

SoFew
02-22-2005, 11:09 AM
Thanks for your advice johnraines. I read the f****** manual http://forums.ubi.com/groupee_common/emoticons/icon_razz.gif for a change and found out that, as you say, the return key fires the missile and not the spacebar - for the F15 anyway. I am now to be feared in the skies above! http://forums.ubi.com/groupee_common/emoticons/icon_cool.gif

Cheers http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

SoFew...