PDA

View Full Version : All objects in settlers 7 see through



dracopheonix
12-18-2010, 03:36 PM
very annoying graphics problem that i cant seem to fix. never had this problem before the patch.
everythig in the game is faded out. almost like distant objects. my computer is high end and all drivers are up to date. nothing seems to work and the game is completly unplayable.

Suptop
12-18-2010, 03:47 PM
Go to graphics manu, set all on default and restart computer + pc game.

dracopheonix
12-18-2010, 05:43 PM
Tried this, no effect everything still looks like glass.

franpa9
12-18-2010, 05:55 PM
if you zoom in does the glass effect fade?

dracopheonix
12-18-2010, 06:18 PM
no its the same at any zoom. every other program i run is fine its wierd. ground looks ok everything else ie glassed.

franpa9
12-18-2010, 06:23 PM
Go to

"My Documents\Settlers7" and delete options and soundsettings ini files then run the game.

dracopheonix
12-18-2010, 06:32 PM
no effect still the same http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

dracopheonix
12-19-2010, 07:10 AM
ok still a ongoing problem. ive done a full reinstall of the game set the seting at lowest and altered the setting on my graphics card nothing seems to work, pls help im at my wits end here :P

Suptop
12-19-2010, 08:11 AM
Have you played the Settlers 7 demo before you bought the cd? Because if it was okay by then the problem could be your software itsself. In that case you should go back to the store where you bought the game and get a new CD

franpa9
12-19-2010, 11:33 AM
Update your video drivers or if you had done that recently, downgrade them.

dracopheonix
12-19-2010, 11:41 AM
Played the game it worked fine even completed the story. everything ran fine, also done the upgrade downgrade thing without sucess.
btw thanks for the help so far keep it coming.

Mr_Shade
12-19-2010, 11:44 AM
If you are still having issues, please make sure you contact Ubisoft Support.

This forum is not intended to replace direct support, which Ubisoft Support can offer.

Contact information can be found either in the game's manual www.ubi.com (http://www.ubi.com) or you can use the weblink in my signature.

Bascule42
12-20-2010, 01:22 PM
Having the same problem. It only started today however. Game was running fine before. There have been no hardware changes to my system. However, I did install the new Catalyst 10.12 drivers. So, Im gonna roll back to 10.11 now and will report back. (But to be honest, Im sure I played S7 *after* the installation - but I could be wrong, so I will give it a go).

Nope, same with 10.11. Which of course was working fine.

Does nayone know if Ubi have introduced any small change over the last few days? As I say the game was working fine yesterday, but now Trees & Building are invisible.

Anyway for, Im gonna contact support in the emantime.


EDIT: OK, it's working now. The catalyst 10.12 control panel did not seem to have an option for disabling Catalyst AI - at least none that I could find. After the roll back to 10.11 I (as has been suggested) disabled Catalyst AI and all objects are working fine.

But this does present a problem for future AMD graphichs driver updates. If there is no option to turn off Catalyst AI then this issue may remain.

Going to leave the support ticket open for now as the dxdiag I attached contains info from the 10.12 drivers.

franpa9
12-20-2010, 04:23 PM
I'm sure such an option will eventually get added to the new control panel in AMD's drivers. It IS beta after all.

dracopheonix
12-26-2010, 04:42 PM
Thought it was going to happen but no luck even with the old drivers and ai turned off no skins on anything just see through objects. hoping that tec support will come up with something.

dracopheonix
12-26-2010, 04:46 PM
all the shadows and the lights are fine its just the objects.

franpa9
12-26-2010, 06:02 PM
Did you try Bascule42's suggestion? Downgrade drivers and control panel then disable Catalyst AI.

dracopheonix
12-27-2010, 06:26 AM
Yep did both. nope this game dosnt like me anymore :P

keith.mcilveen
12-27-2010, 03:46 PM
I too have the exact same issue. I have disabled Catalyst AI but still having the 'glass houses' issue.

Any other idea apart from the ones above?

thanks

keith.mcilveen
12-27-2010, 04:11 PM
Got it working -

On the Catalyst Control Centre - 3D section ensure you tick all the 'Use application settings'