PDA

View Full Version : Tweak! High quality shadows on "low" that look better then "high"!



Corky-
06-21-2007, 08:03 PM
Hey all! I have a treat for ya.

First off, here's the product:

http://imgplace.com/directory/dir4629/1182476662_4485.jpg

http://imgplace.com/directory/dir4629/1182476665_8317.jpg

http://imgplace.com/directory/dir4629/1182476668_4186.jpg

http://imgplace.com/directory/dir4630/1182476671_5841.jpg

So, I was messing around looking at the legal tweaks thread and I found the shadow tweak. It wasn't until about 15 minutes later of applying the tweak that I thought I could make it even better! I noticed in game with the shadow setting on "low" you have a much harder shadow with more intense lines. So I figured, well.. since I can alter the resolution of shadows, why don't I bump up the shadow's "low" setting so it doesn't have as much as a performance impact of having it set on "high"? Well, I did, and the outcome is fantastic! The shadows are harder lined and more intense and look tons better then having the blocky inconsistent shadows that come with the "high" setting.

Here's the tweak:

Open up your KellerEngine.ini file that's located in Ubisoft\Tom Clancy's RB6:V\KellerGame\Config\PC.

Open the file with notepad/wordpad and press ctrl+f. Within the box type Shadow and hit enter. This will highlight the setting you need to alter. Alter these lines to:

ShadowBufferResolution=3072
MaxShadowResolution=2048
MinShadowResolution=1088

Now, I know what you're saying. "Are you crazy! That'll decrease performance by a long shot!" WRONG! Since you're using the setting "low" in game, the extra passes that softened the shadow are no longer used as much, resulting in a hard higher resolution shadow. I consider these shadows "Doom 3 Shadows" as Doom 3 had very hard edged shadows with no softening at all, and that game ran like a dream for me. I tried to recreate that here.

I realize there is a tweak thread, but I didn't want this to be swallowed by it as the tweak thread hasn't been updated in a while with actual tweaks.

Of course, back up your old file before applying the tweak! In case you don't like them.

Happy fragging guys! Enjoy!

<span class="ev_code_RED">EDIT: The image links do work, just sometimes code is displayed. Just close it out and click the link again and eventually the picture will show up. Sorry for the less then decent host! It was all I could find.</span>

<span class="ev_code_RED">EDIT 2: For those of you wondering, my frame rates hover between 42-50fps. I was using shadows set to "high" before, but was less then enthusiastic about how the "high" setting looked like a "low" setting. Those pictures are in "low" mode, but with higher resolution shadows and much better performance then using "high" mode. You can tweak the values even more if you would like, the above are performance/quality settings I found to be a great middle ground!</span>

Tek-fu
06-22-2007, 07:32 AM
I'm gonna have to try this when I get home this afternoon.

Cheers. http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

mike_j_b
06-22-2007, 09:51 AM
i was just woncering has this tweak been tried and tested with pb on ?

Snipe4Me
06-22-2007, 10:44 AM
Am a sucker for TWEAKS so I'll comeback later on to tell you what happened to mine when I did the change.

This will not altered any other tweaks I have done before, right? More to the point, this will, in no way, alter my Widescreen tweak?

Corky-
06-22-2007, 01:13 PM
This won't alter any kinda of tweak you've already applied. It's strictly shadows. This is a legal tweak, as it is under the "Legal Tweak Thread", the only difference is that the tweak in the thread is strictly for performance interests. Think of this as more of an optimization, it will perform better than shadows set to "high" but it will look better too. So you'll still have a performance hit with having shadows on in the first place, but this tweak will not even come close to taxing your system as much as the "high" setting will.

Snipe4Me
06-22-2007, 05:13 PM
OK, before I go altering my KellerEngine.ini, I want to ask something else here.

I am there right now and I see 2 sets of SHADOW things I can switch and I want to make sure I have to do it in one place or two places or in the correct place if only done once.

This is what I see under:

[D3DDrv.D3DRenderDevice]
UseTrilinear=True
LevelOfAnisotropy=1
UseStaticLighting=True

<span class="ev_code_RED">ShadowBufferResolution=512
MaxShadowResolution=512
MinShadowResolution=16</span>

ShadowResolutionScale=2.0
BlurBufferResolutionDivisor=3
DisableShaderModel3=False
DisableMultiLightPath=True
DisablePrecaching=False
DisableOcclusion=False
bEnableFastShaderCaching=True
MaxTranslucencyLayers=0
ShaderPath=..\Engine\Shaders
AdapterNumber=-1
Gamma=1.800000
BlurNightVision=0.4
BlurHeatVision=0.7



But I also have another set under:


[OpenGLDrv.OpenGLRenderDevice]

UseTrilinear=True
LevelOfAnisotropy=4
UseStaticLighting=True

<span class="ev_code_RED">ShadowBufferResolution=1024</span>
<span class="ev_code_RED">MaxShadowResolution=128</span>
<span class="ev_code_RED">MinShadowResolution=64</span>

ShadowResolutionScale=2.0
BlurBufferResolutionDivisor=3
DisableShaderModel3=False
DisableMultiLightPath=True
DisablePrecaching=False
DisableOcclusion=False
bEnableFastShaderCaching=True
MaxTranslucencyLayers=0
ShaderPath=..\Engine\Shaders
AdapterNumber=-1
Gamma=1.800000
BlurNightVision=0.4
BlurHeatVision=0.7

Ok, it may very well be that I wasn't paying much attention to your post or I grabbed the wrong file to play on but... what gives here? Hook a brutha up before I destroy what it could be a beautiful relationship with the game! http://forums.ubi.com/images/smilies/16x16_smiley-wink.gif http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

Corky-
06-22-2007, 08:31 PM
Hey, Snipe

The correct one is the D3DRender line. Short and sweet. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

On another note, I was testing around some lines and the lowest values I would use are 2048/1024/1024. In that order, starting with ShadowBufferResolution.

Also, for those interested in extreme tweaking for performance, I found that 2/1/1 removes all shadows except static ones. These values would set the shadows lower than "very low" would in the game options. Just thought I'd throw that out there. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Snipe4Me
06-22-2007, 09:05 PM
Originally posted by Corky-:
Hey, Snipe

The correct one is the D3DRender line. Short and sweet. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

On another note, I was testing around some lines and the lowest values I would use are 2048/1024/1024. In that order, starting with ShadowBufferResolution.

Also, for those interested in extreme tweaking for performance, I found that 2/1/1 removes all shadows except static ones. These values would set the shadows lower than "very low" would in the game options. Just thought I'd throw that out there. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Ahhh roger roger... I was just going to say that I was experiencing MAJOR LAG at the nevada dam level after doing this to both sets of parameters... I'll go back to the original and test again.

Snipe4Me
06-23-2007, 10:22 AM
Revision 2...

Ok, went back and re edit my ini file and it improved tremendously, graphics are much much better now than before with that TWEAK... I also changed the options in the VIDEO main menu to what you had on your 1st image.

Now, one little thing that I can't get around... I play fine for 1 level but, as soon as the game saves and I start a new level, the lag starts and I can't seem to recover unless I restart my PC.

I know is not overheating cos I am barely at 65 degree C's on each card and I don't believe the installaton of Nvidia Ntune can be causing all this ruckus.

What is the formula you have used to set those resolutions? maybe I can play with them for my rig. also, what are your system specs, perhaps you have a high-end whereas mine is just mid-end and I can't play at those settings.

Here are mine:

Win XP w/SP2 latest updates
EVGA 680i mobo
E6300 @ 2100mhz (thanks to the Magic tricks of Nebula!)
OCZ 2GB SLI RAM 1066mhz (5-5-5-15T, again, thanks to Nebula)
2 120mm Fans, CPU Fan & chipset fan running at 100% all the time (yep, nebula!)
BFG 7800 GTX O/C x 2 (SLI) latest driver
SB Audigy (Latest Driver)
400GB HDD 7200.10 16mb cache
TT 650w PSU

Thanks

Corky-
06-23-2007, 07:14 PM
Originally posted by Snipe4Me:
Revision 2...

Ok, went back and re edit my ini file and it improved tremendously, graphics are much much better now than before with that TWEAK... I also changed the options in the VIDEO main menu to what you had on your 1st image.

Now, one little thing that I can't get around... I play fine for 1 level but, as soon as the game saves and I start a new level, the lag starts and I can't seem to recover unless I restart my PC.

I know is not overheating cos I am barely at 65 degree C's on each card and I don't believe the installaton of Nvidia Ntune can be causing all this ruckus.

What is the formula you have used to set those resolutions? maybe I can play with them for my rig. also, what are your system specs, perhaps you have a high-end whereas mine is just mid-end and I can't play at those settings.

Here are mine:

Win XP w/SP2 latest updates
EVGA 680i mobo
E6300 @ 2100mhz (thanks to the Magic tricks of Nebula!)
OCZ 2GB SLI RAM 1066mhz (5-5-5-15T, again, thanks to Nebula)
2 120mm Fans, CPU Fan & chipset fan running at 100% all the time (yep, nebula!)
BFG 7800 GTX O/C x 2 (SLI) latest driver
SB Audigy (Latest Driver)
400GB HDD 7200.10 16mb cache
TT 650w PSU

Thanks

Hey Snipe,

I'm not too sure what could be causing your problem as you do have me beat in system components. I'm running:

Win XP SP2; all updates
A8N32 Sli Deluxe Mobo
Random sticks of RAM, 2gb
AMD 4200+ X2 - Stock 2.2ghz, OC'd to 2.6
eVGA 7900gs KO, slightly OC'd

The only thing I can think of is that Vegas doesn't like SLi too much. I'm not 100% certain on this, but I think I remember reading of people having problems running Sli. Are you sure both cards are being utilized? It seems strange you're able to play fine one level then have a performance hit the next. To top that off you have to restart to "fix" it? Something's not right here.

Which resolutions are you talking about? The shadows, or the display resolution? The shadow resolution I just played around with in even integers. To clarify on the actual settings for what I believe them to be:

ShadowBufferResolution - If I had two guesses at what this actually means... I would say it either buffs out the shadow to soften it per pixel or it's the allocated memory of the combination of the max and minimal resolution

MaxShadowResolution - Self explanatory, the max resolution the shadow will ever achieve

MinShadowResolution - Self explanatory, the minimal resolution the shadow will ever achieve

I use a widescreen monitor with a max res of 1440x900. I use the 1280x960 because the HUD in the widescreen patch doesn't scale. The 1280x960 is a default selection in the video options for me.

Also, the ShadowBufferResolution is the biggest factor in these settings. I could set the shadow resolution to 4096 (extremely high) but have a buffer resolution of 64, and the shadows would look like the 64. So play around with that value and see how it affects your performance. Unfortunately, it'll be near impossible to see what my system is doing that yours isn't or vice versa. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif