PDA

View Full Version : 1.03 patch is out... woo!



Whisker_Biscuit
05-31-2005, 09:24 AM
I know others have been informed to wait til Rhou says something, but try your update... I'm so excited!

Notes:
================================================== ==============================

Splinter Cell Chaos Theory v1.03 Patch Contents

================================================== ==============================

Overview
--------

Highlights of patch 1.03 include various fixes and minor enhancements.

Bug Fixes
---------

- Partially corrected skinning crashes when AlienGUIse is present.

- Fixed divergences caused by mouse interactions after quickloading.

- Fixed Network NAT traversal issues through certain routers

- Intel IG fixes (if software vertexprocessing not supported, disabled mouse delag if event queries are not supported)

- Fixed graphic problems resulting in one of the player losing his HUD and being unable to use night vision and messed-up
thermal vision. This happened for users playing against another player under particular hardware configurations.

- Fixed crash when menu owner gets deleted before the disconnection is processed.

- Fixed disconnection if the client was in the in-game chat while the host was restarting the game.

- The Voice chat port is now properly punched through for connection through router.

- [Versus] Corrected the Uzi problem with ATI Radeon 9700 in Versus.

- [Versus] The host no longer see where bombs are placed on the radar. He has to seek for them, just like clients.

- [Versus] In the Aquarius map, a Mercenary grabbed by a Spy doesn't get stuck in the crunching box; he dies with the Spy.

- [Versus] The tutorial mode appears clearly for everyone in the lobby.

- [Versus] Correction on a Camera bug that always displays its detection information.

General Improvements
--------------------

- Added a specific message when the Coop player is disconnected because the partner left.

- Connection to ubi.com through HTTP proxy is now properly supported. If you are using an HTTP proxy, you must edit the
SplinterCell3.ini file usually located (depending on your system) in:

C:\Documents and Settings\All Users\Application Data\Ubisoft\Tom Clancy's Splinter Cell Chaos Theory\SplinterCell3.ini

Then, add the following lines in your splintercell3.ini under the [UBI.COM] section with your web proxy settings:

[UBI.COM]
ProxyAddress=
ProxyPort=

Note: By default, this folder is hidden by Windows. To browse it, you must do the following in Explorer:

Select Tools->Folder options->View and check the "Show hidden files and folders" radio button.

- [Versus] A new message from the host if the clients leave the game via the "Quit game" button.

S.a.S-Akbari
05-31-2005, 09:26 AM
YEA!

scope2005
05-31-2005, 09:28 AM
YAY! its updating..

So what does this patch do? i cant tell untill ive downloaded it..

Hopefully squat and the new co-op maps are in, the uzi has been nerfed, and the thing with music not playing has been fixed...

fingers crossed http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

EDIT: HUH? no new maps in that patch.. hmm.. why release a patch if new maps are just around the corner?

Vth_F_TipX
05-31-2005, 09:29 AM
THAT ROXXXX ^^

Dreakon1313
05-31-2005, 09:30 AM
Kick ***! Thanks for informing us!

element54
05-31-2005, 09:33 AM
guess we owe pettor an appology, he mentioned it was out yesterday. the mods closed the thread thou cuz he linked to the wrong patch (SC1-patch 1.03)

cheers

S.a.S-Mosar
05-31-2005, 09:36 AM
I already thought they would never gonna fix some of the most annoying bugs/problems in versus. YAY! This means they listen to us, atleast on some things.

eTo-NoSiS106
05-31-2005, 09:51 AM
anyone know where i can get a direct download, i accidentaly deted the autopatcher when i deleted the sp directory (needed hd space)

scworld
05-31-2005, 09:55 AM
WOOOOOT

SoBloedWaere
05-31-2005, 09:56 AM
Originally posted by eTo-NoSiS106:
anyone know where i can get a direct download, i accidentaly deted the autopatcher when i deleted the sp directory (needed hd space)
http://patches.ubi.com/splinter_cell_chaos_theory

C.A.T.ops_v2.0
05-31-2005, 09:59 AM
Wow, this really suprised me. I wasn't expecting this patch to be out for atleast a couple more months. http://forums.ubi.com/images/smilies/16x16_smiley-indifferent.gif

I mean, it's great that they finally fixed all of the major bugs but... yea the game has been out for 2 months now. Ah well, I should be greatful. Thanks UBI.

Gangxta123
05-31-2005, 10:09 AM
w00t!!!! Im Updating now this is awsome.... Thx ubi!!!!!!!!!
Our dreams have finaly came out of the anger that all the bugs were makign us angry are now fixed and now we can enjoy it!!!!!

BooBerry.Ck
05-31-2005, 10:11 AM
id bet your 5 dollars this patch will cause new and completey differant bugs for us to complain about http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

Dreakon1313
05-31-2005, 10:11 AM
Originally posted by scope2005:
EDIT: HUH? no new maps in that patch.. hmm.. why release a patch if new maps are just around the corner?
Maybe to actually fix things before the maps are released? No use releasing maps when half the community cant even play.


Originally posted by BooBerry.Ck:
id bet your 5 dollars this patch will cause new and completey differant bugs for us to complain about http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif
That's a given...

element54
05-31-2005, 10:15 AM
I wonder if Ubi saw my post before and added the ghost and fireworks to the patch update... lol. that would be a waste of valuable resorces ehh.

Gangxta123
05-31-2005, 10:15 AM
Originally posted by BooBerry.Ck:
id bet your 5 dollars this patch will cause new and completey differant bugs for us to complain about http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

Yup I guess your right lol, for every fix theres one problem....Oh well lets see if there are no bugs (Doubtfully)lol......And lets see which ones occur now.......

BooBerry.Ck
05-31-2005, 10:28 AM
Originally posted by Dreakon1313:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by BooBerry.Ck:
id bet your 5 dollars this patch will cause new and completey differant bugs for us to complain about http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif
That's a given... </div></BLOCKQUOTE>

SHUSH, i'm trying to make some money here. god!!

Doppelgofer
05-31-2005, 10:35 AM
....has co-op been fixed?

Gangxta123
05-31-2005, 10:38 AM
Originally posted by BooBerry.Ck:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Dreakon1313:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by BooBerry.Ck:
id bet your 5 dollars this patch will cause new and completey differant bugs for us to complain about http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif
That's a given... </div></BLOCKQUOTE>

SHUSH, i'm trying to make some money here. god!! </div></BLOCKQUOTE>

Lol phhew...was about to bet that mone ywit hBoo thx for toping me Dreakon!!hahaha!!!!


Originally posted by Doppelgofer:
....has co-op been fixed?
IM no sure havnt tried out Coop yet I will later whne Kenko logs into Ventrilo...http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

scworld
05-31-2005, 10:56 AM
Coop seems as buggy as before with connecting.
Uzi bug has been fixed.

EDIT: only tried coop with 1 connection.

Doppelgofer
05-31-2005, 11:14 AM
yeah i've just tried co-op....the framerate is still way down aswell

...only difference was i was able to host a game for the first time ever

Spartan_M.A.D.
05-31-2005, 12:44 PM
I still cant get my mic to get past the "configuration" utility http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

suomursu
05-31-2005, 12:45 PM
omg i can't isntall this one.. I tried both the autopatcher and downloading the patch. It starts installing but then freezes, this message appears then : "Old file not found. However, a file of the same name was found. No update done since file contents do not match."
Wtf is matter with this? The other patches worked fine but this one isn't. Please help if you can, thanks ^^

Rhoulette
05-31-2005, 12:49 PM
<span class="ev_code_pink">I posted the Official North American version links in the splintercell.com news (http://splintercell.com/us/newspost.php?id=11184) section. Many of these fixes were done at your request. Hopefully they fix more than they break (patches can be so troublesome that way).

Enjoy! http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif </span>

daranz
05-31-2005, 12:52 PM
[Versus] Corrected the Uzi problem with ATI Radeon 9700 in Versus.

<span class="ev_code_RED">HALLELUJAH!</span> FINALLY!

Zen-PoD
05-31-2005, 01:02 PM
I have the same prob suomursu... Uninstalling and reinstalling norm works... But wait, oh that's right, ubi games can't be uninstalled the normal way... If u don't believe me try it... Click the uninstall icon in the game folder it will do NOTHING. This prob also needs to be fixed UBI... Ur game's can't be uninstalled.

suomursu
05-31-2005, 01:13 PM
Zen-PoD, there has to be another way http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif well im too tired to be bothered to reinstall the game, I'll look into that matter tomorrow. I hope someone get me a better answer :P

Soviet_Sapper
05-31-2005, 01:24 PM
AHHH! No europe or UK Patch http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif - only US. I decided to try, and no, it doesn't work...

"It seems your version is incompatible.."

Doppelgofer
05-31-2005, 01:29 PM
Originally posted by Soviet_Sapper:
AHHH! No europe or UK Patch http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif - only US. I decided to try, and no, it doesn't work...

"It seems your version is incompatible.."

well i'm from uk and patched it fine

Laddil
05-31-2005, 01:56 PM
*sigh* Did they FINALLY fix co op yet?

Gangxta123
05-31-2005, 01:57 PM
Cool now its in the Main Splinter Cell New Page so everyone will get it now. I was playing a while ago and a max of 30 people had it the rest were still playing 1.02 and ther ewas alot of those 1.02 servres. SO go and download it guys.

N3ckBreak3r
05-31-2005, 01:59 PM
omfg, my patch also freezes, what the hell is this!?

N3ckBreak3r
05-31-2005, 02:18 PM
yeha, it works now, the path frozed at 11%, but continued 5 minutes later, but if i pressed a key, the path collapsed, so i relaxed on my bed and waited^^

scworld
05-31-2005, 02:19 PM
It takes time.
I dont know if it works for EMEA version, but if not: EMEA is always a couple of days ( 1 to 3) behind.

Dreakon1313
05-31-2005, 02:34 PM
Yes, mine froze too but if you let it continue regardless it will eventually pick itself up again and continue patching.

Also, for those that dont want to grab the patches from the Autoupdater or from Ubi, they are all available at Splinter Cell Xtreme (registration required). http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

cheese_thief
05-31-2005, 02:54 PM
Hell YEA! They fixed the Uzi problem!

Brutusn
05-31-2005, 03:50 PM
Originally posted by suomursu:
omg i can't isntall this one.. I tried both the autopatcher and downloading the patch. It starts installing but then freezes, this message appears then : "Old file not found. However, a file of the same name was found. No update done since file contents do not match."
Wtf is matter with this? The other patches worked fine but this one isn't. Please help if you can, thanks ^^

Hi I had the same problem. I use the coop load out editor and I think you to? But you must set back the original file (dynamic-pc.umd), I did it and it worked for me!

Doppelgofer
05-31-2005, 04:03 PM
Originally posted by Laddil:
*sigh* Did they FINALLY fix co op yet?

absolutley not

friendly_skater
05-31-2005, 05:02 PM
i need help

i updated the patch fine

1.2 to 1.3 one

i can even join the 1.3 servers

but.. before you log into your account, if you look at the lower right hand corner, it still says 1.2 !!!

is it like that for you guys as well ? or is it just me?

pk1209
05-31-2005, 05:23 PM
way to fix the save game bug.... w00t

oh wait, you didn't fix it...

Ninj3r
05-31-2005, 06:11 PM
Lol, so they haven't fixed coop at all?
God, was anticipating a new patch hoping I could finally play co-op properly.. ah well, guess i'll wait another few weeks/months for another one :/

Doppelgofer
05-31-2005, 06:16 PM
Originally posted by Ninj3r:
Lol, so they haven't fixed coop at all?
God, was anticipating a new patch hoping I could finally play co-op properly.. ah well, guess i'll wait another few weeks/months for another one :/

i think they've buggered co-op up beyond repair

TacoLaMmY
05-31-2005, 06:17 PM
Not sure how I should feel about this patch since it didn't fix any of the problems I have with the game.

Congrats I guess if this livened up your play experience.

Dreakon1313
05-31-2005, 06:41 PM
I think this patches highlight is the Uzi fix. If you don't have that card I guess you don't have too much to appreciate with this patch.

Hopefully the next one will be a bit more for Coop. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

I.S.F-Dixxhead
05-31-2005, 07:15 PM
Hopefully the next one will deliver new Maps ^^ Now that would be cool http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif (even though the bugfixes of course have priority)

Laddil
05-31-2005, 08:38 PM
Originally posted by Doppelgofer:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Laddil:
*sigh* Did they FINALLY fix co op yet?

absolutley not </div></BLOCKQUOTE>

Yup, just tried it. Still cannot join any games. It took me about 9 tries at joining games to get into one which lagged like hell. 1.03 did absolutly nothing to help my non functioning co-op game. Congratulations ubisoft, you screwed up again on trying to fix co op. Better luck next time, GG kthxbai.

AppleJacks-Ck
05-31-2005, 08:48 PM
woohoo!

talk to muh uzi!

redskirts
05-31-2005, 09:04 PM
well for the uzi bug yeah, as for the other twenty things on that list spekkio and mosar sent BOOOOOOOOOOOOOOOOOOOOO!!! Not a **** thing has changed to improve gameplay, big dissy, tutor mode symbol, who the heck comlained about that? We complained during the freggin beta about that. How bout MT, sticy cam problem, connection issues, flashlight, eax, camo noise....well one out of twenty aint bad.

Sorry for the coop people, looks like your up shiznits creek. http://forums.ubi.com/images/smilies/mockface.gif

friendly_skater
05-31-2005, 09:22 PM
Originally posted by friendly_skater:
i need help

i updated the patch fine

1.2 to 1.3 one

i can even join the 1.3 servers

but.. before you log into your account, if you look at the lower right hand corner, it still says 1.2 !!!

is it like that for you guys as well ? or is it just me?

plz guys

just tell me if you guys see that 1.2 before log in

AppleJacks-Ck
05-31-2005, 11:49 PM
never really payed attention to that but mine says 1.2 and i played fine on servers today

timmieboy2
06-01-2005, 12:19 AM
if i start it normal it says 1.03, but when i got to svm it says 1.2 http://forums.ubi.com/groupee_common/emoticons/icon_eek.gif

friendly_skater
06-01-2005, 01:43 AM
i guess im not the only one

thx guys i appreciate it

seems weird we can all play together with people who patched to the latest 1.3 but it says 1.2 on the VS. log in screen...

Neo-Humanity
06-01-2005, 01:58 AM
Originally posted by timmieboy2:
if i start it normal it says 1.03, but when i got to svm it says 1.2 http://forums.ubi.com/groupee_common/emoticons/icon_eek.gif

Two different executables, two different engines, two different versions. SP/Co-Op = v1.3, SvM = v1.2. In the next patch SP/Co-op will be v1.4, and Svm will be v1.3.

And hooray for me never having problems with Co-Op.

*Hugs himself*

suomursu
06-01-2005, 02:01 AM
Originally posted by Brutusn:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by suomursu:
omg i can't isntall this one.. I tried both the autopatcher and downloading the patch. It starts installing but then freezes, this message appears then : "Old file not found. However, a file of the same name was found. No update done since file contents do not match."
Wtf is matter with this? The other patches worked fine but this one isn't. Please help if you can, thanks ^^

Hi I had the same problem. I use the coop load out editor and I think you to? But you must set back the original file (dynamic-pc.umd), I did it and it worked for me! </div></BLOCKQUOTE>

wow! thanks! didn't notice that. Gonna try it as soon as i get to my computer (downstairs :P)

S.a.S-Akbari
06-01-2005, 02:13 AM
Versus dint get patched with the second patch (1.2) so it stayed 1.1, but it did now and so it increased a version (1.2) http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

kdbaraka
06-01-2005, 04:14 AM
Patch installed fine here, but co-op remained exactly the same way with all its problems.

Sceptre6666
06-01-2005, 07:07 AM
*Hurray for me for always having a functioning coop*

(And yes, it is sweet.)

blackguy32
06-01-2005, 07:33 AM
Technical problems should come before gameplay fixes

pisipoisu
06-01-2005, 07:56 AM
The problem that you can't connect to most of the servers is that, because those people who are making servers have routers and they havn't opened their ports, so you can't join, but doesn't the pach fix the qickload in coop?

IllumiC.A.T.
06-01-2005, 08:19 AM
Yes! I will start playing SC once more..Haora que ay un patch.lol

Spekkio9
06-01-2005, 09:46 AM
Argh, no MT fix http://forums.ubi.com/images/smilies/51.gif

XyZspineZyX
06-01-2005, 09:53 AM
I have a wierd problem. The patches I download from the ubi server don't work. I have to download my patches from a site like 3dgamers.com.http://forums.ubi.com/images/smilies/16x16_smiley-indifferent.gif

Brutusn
06-01-2005, 10:27 AM
Stange thing, installed new patch, and coop doesn't work anymore!!! It worked when we had the 1.02 patch!

Chimera87
06-01-2005, 10:32 AM
yea kinda irritating.....

i was like WOHOOO voice works and now i cant even play anymore.....

i just hope that the LAN isnt like this too, cuz thats the only way out we now have http://forums.ubi.com/images/smilies/cry.gif

pinksteady
06-01-2005, 11:15 AM
well my comp used to crash coop games on LAN after a quickload if I moved the mouse, and now I've installed the 1.03 patch ... both the comps which play crash it! It has actually made it worse, yipee!

Here's to waiting then...

RedSwirl
06-01-2005, 06:38 PM
Originally posted by S.a.S-Akbari:
Versus dint get patched with the second patch (1.2) so it stayed 1.1, but it did now and so it increased a version (1.2) http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Aha

Thanks for clearing that up. But it seems that a lot of people who play SvM still haven't downloaded that patch yet. I still couldn't join half the games there. Guess I just need to give everyone more time.

Anyway, I never really had any problem with the Uzi but I guess a new patch is always good.

Defcon_5
06-02-2005, 02:29 AM
Originally posted by Spekkio9:
Argh, no MT fix http://forums.ubi.com/images/smilies/51.gif

I give up any hope that Ubi will fix anything regarding gameplay issues in SvM. Perhaps they are so sure, that its fine as it is http://forums.ubi.com/images/smilies/51.gif