PDA

View Full Version : Huge sutter on resuming Far Cry Primal after accessing in-game menu



jdj9
04-15-2017, 10:25 PM
Hello!

First of all i wanna say that i am really enjoying the game, its one of the most beautiful and entertaining games i ever played. The scenery and landscapes are beyond amazing.

So, I got a weird problem with my game that really impacts the whole experience. I'm really desperate, I've been trying to find a solution for about 2 weeks now, but i can't.

When i access the menu by pressing ESC or the in-game menu by pressing M for map, K for skills etc, i get a HUGE stutter and frames drop for 1-2 seconds when i press ESC to resume the game. This stutter does not appear anywhere else, only when i resume the game after accessing any of the menus. The performance is really good i get very good FPS at about 80 average at 1440p maxed.

My specs:

Mobo: Asus Maximus VII Ranger
CPU: i7-4790k @4.4Ghz
RAM: 32GB @ 2400Mhz CL11
GPU: 2 x GTX 1070 FE SLI Hybrid Cooled @ 1911Mhz Auto Boost, not overclocked
SSD 512GB
Monitor: Dell S2716DG 144hz, G-Sync

The temps are excellent no issues there. I do not get this issue with other games. The latest Nvidia drivers are installed.

Any ideas?


Thanks
Jo.

sheik_92
05-04-2017, 07:48 PM
This is probably because the game doesn't take proper advantage of multi-core processors. I didn't have that kind of issue, but when i alt-tabbed the game even for just a second, it would get very stutterly for like 10 or 15 seconds. What i did to solve it was reset the processor affinity values in the task manager, but the procedement has to be made everytime you launch the game, which is a little annoying:
Launch the game, then open task manager (ctrl-alt-esc), go to details, find the game process, click with right button, set affinity, uncheck core 0, ok, and then check it again.

jdj9
05-04-2017, 08:07 PM
This is probably because the game doesn't take proper advantage of multi-core processors. I didn't have that kind of issue, but when i alt-tabbed the game even for just a second, it would get very stutterly for like 10 or 15 seconds. What i did to solve it was reset the processor affinity values in the task manager, but the procedement has to be made everytime you launch the game, which is a little annoying:
Launch the game, then open task manager (ctrl-alt-esc), go to details, find the game process, click with right button, set affinity, uncheck core 0, ok, and then check it again.

So I've launched the game to try what you have suggested but the problem was already fixed because i previously made a clean install of the latest Nvidia drivers. Up until now i was just updating the drivers (not a clean install). Doing this fixed my issue but (surprisingly) it didn't cross my mind at the moment of installation, lol.

I thought that it might have something to do with SLI but i tested also on one GPU but still, same results. So i just gave up.

I wish i had discovered this earlier so i could enjoy the game a lot more before completing the main campaign. Now i am just wandering the landscapes of Oros helping my fellow Wenjaaaaa!!.

Thanks for your help.
Jo.

jdj9
05-05-2017, 11:27 PM
This is probably because the game doesn't take proper advantage of multi-core processors. I didn't have that kind of issue, but when i alt-tabbed the game even for just a second, it would get very stutterly for like 10 or 15 seconds. What i did to solve it was reset the processor affinity values in the task manager, but the procedement has to be made everytime you launch the game, which is a little annoying:
Launch the game, then open task manager (ctrl-alt-esc), go to details, find the game process, click with right button, set affinity, uncheck core 0, ok, and then check it again.

So I've launched the game again today and guess what... the problem appeared again... FML... i don't know what the problem is.

I've also tried your method but still... nothing...

It is killing me. It is extremely annoying =/

jdj9
05-06-2017, 01:31 AM
This is probably because the game doesn't take proper advantage of multi-core processors. I didn't have that kind of issue, but when i alt-tabbed the game even for just a second, it would get very stutterly for like 10 or 15 seconds. What i did to solve it was reset the processor affinity values in the task manager, but the procedement has to be made everytime you launch the game, which is a little annoying:
Launch the game, then open task manager (ctrl-alt-esc), go to details, find the game process, click with right button, set affinity, uncheck core 0, ok, and then check it again.

I finally found what the freakin problem was!!!!

I was sure that it had to do something with either SLI, G-Sync or something in Nvidia control panel.

Well, if i disabled G-sync the problem went away but i wanted to use G-sync.. it is a feature that i paid for and want to use.

So i carried on testing other settings hoping to find another way around this problem.

In the Nvidia control panel, i re-enabled G-Sync and under 'manage 3d settings' i set the Vertical sync from 'use the 3d application setting' to 'off'. This completely solved the issue.

Although it doesn't make any sense, it works. Since Vsync was off in the game, the setting in Nvidia control panel should not have mattered since it was set to 'use the 3d application setting'.
Anyway, now its fine at last :)