PDA

View Full Version : Music and it's associated nightmares!



harryluck
03-30-2004, 08:15 AM
Okay... who has figured out where the DynamicMusic.LUA is stored, i've looked in all the .pak files and it's nowhere to be found!?

You have to select a music-script in the mission properties dialog, i have the music library that i've tried to make, but... i can't use it because of this... or is that not the case?! ... it sure seems it... if anyone has any clues in the music direction... please, share your knowledge... it's gold!!! http://ubbxforums.ubi.com/infopop/emoticons/icon_wink.gif

Harry.

harryluck
03-30-2004, 08:15 AM
Okay... who has figured out where the DynamicMusic.LUA is stored, i've looked in all the .pak files and it's nowhere to be found!?

You have to select a music-script in the mission properties dialog, i have the music library that i've tried to make, but... i can't use it because of this... or is that not the case?! ... it sure seems it... if anyone has any clues in the music direction... please, share your knowledge... it's gold!!! http://ubbxforums.ubi.com/infopop/emoticons/icon_wink.gif

Harry.

Key-Node
03-30-2004, 09:57 AM
DynamicMusic.lua is not used.
For dynamic music definition look into DataBase View Music tab.

harryluck
03-30-2004, 10:04 AM
i've done that... i've set up my theme / patterns etc... but, i can't get the damn thing to play using area triggers and any of the sound entites it would appear? I'm clearly doing something wrong, however... the manual doesn't seem to explain the music system, and how you can play them in the game very well?!

Harry.

harryluck
03-30-2004, 11:32 AM
okay... i'm so confused... i can't even get CryTeks music to play! ...

I've loaded 15_Catacombs into the music database view.

I've then made an area shape, and then a MusicThemeSelector entity (i have also tried this with MusicMoodSelector... i get the same thing).

I then pick the MusicSelector with the area pick tool, and then change the MusicSelector Params: DefaultMood : Combat / Theme : M15Jungle.

I get nothing... when i Ctrl-G and waltz into the trigger, i hear nothing! ... if i do the same thing with a sound preset... it's fine... just what the hell am i doing wrong?!

Do i need to set up a trigger that sets the them and then a mood selector too? ... or not?

Harry.

harryluck
03-30-2004, 11:53 AM
okay... i just tried it in the game... and it plays just fine... does the music really not play from triggers etc in the editor? ... it's a little annoying to test?

Harry.

antistar_
03-30-2004, 12:44 PM
Sound can be a little troublesome, yes. Try exiting the editor and reloading the map, and if that fails, test it in the full game.

aka Tim Partlett

harryluck
03-30-2004, 05:08 PM
*from the sandbox manual*

'in order to avoid abrubt changes in music you will want to set the fade in zone of the shape area objects ... by giving it a width'

Does this only work for music to music fades or should the width still fade out the music if it's fading out to no music? ... if so, it doesn't work. I get a hideous abrubt stop, and i have tried about 100 different width settings... am i doing something wrong that anyone can think of?

Harry.

harryluck
03-31-2004, 05:33 AM
bump... bumpity... bump.. has anyone got this to work properly?

Harry.