PDA

View Full Version : General Protection Faults - Help?



XyZspineZyX
10-09-2003, 08:06 PM
I started getting them 3 days ago and have been trying to analyze what the F**K is going on, but am ending up with a
headache and little encouragement.

System Specs -

KT7A-Raid Motherboard v1.2
3x256M PC133 SDRam sticks (768 total Ram)
Geforce 4 TI 4200 w/128M ram
Sound Blaster PCI512
Maxtor 20G HD
TDK 52x24x52 CD-RW
3Com 10/100 905b NIC
Running Windows 2000 as a "Standard PC" not "ACPI"

This is the basics, as you don't need to know what I have
on the RAID side of things for HD's, as they don't factor
into the problem.

When I started getting them, I re-installed and repatched
from the ground up on the computer - still got them.

Yesterday (10/8) I reinstalled my computer as a "Standard
PC" with the Geforce 4 at IRQ 5, SB PCI512 at IRQ 9, and
the NIC at IRQ 11. Please note, that with the "Standard PC"
setting in Windows 2000, it accepts the BIOS settings,
instead of "assigning IRQ" as per the OS. I still can't
change the damn IRQ's from within the OS, but at least I
know they are all on seperate IRQ's, as per system.

Anyway, after re-installing, installing drivers for the RAID
and video card and sound card and patches for the OS and
installing only DirectX 8.1 and NVidia 40.72 Drivers for
the video card - As the 45.23 Drivers and 43.XX drivers
just caused even bigger problems, I loaded the game, patched
it and the started it.

The first time it started, I got into the "LAN" game
settings and started making changes, when I got an actual
"Blue Screen of Death" - nt4_disp.dll was the cause.

Ok, I restart my computer and start up RS again, make my
changes and actually click "launch" and "play", when I
get a General Protection Fault - Main Loop. Please note,
there is NO EVENT ERROR! If there was, I could try to do
something else, but nada.

Third times a charm - I fire it up and get actually get
into the game and start to move around, when it dies with
another GPF.

This goes on for times 4 through 20. I stopped submitting
bug reports after the 10th time, as I was getting frustrated
and my language by this point in time had deteriorated to
that just shy of resorting to black magic and blowing the
company off the face of the earth. If there had been
any way I could have gotten into the game and actually
played, I would have wasted EVERYONE........


Anyway, I tried the FIX as posted in other notes, but that
didn't work.....

Help!

Casper /i/smilies/16x16_smiley-sad.gif

XyZspineZyX
10-09-2003, 08:06 PM
I started getting them 3 days ago and have been trying to analyze what the F**K is going on, but am ending up with a
headache and little encouragement.

System Specs -

KT7A-Raid Motherboard v1.2
3x256M PC133 SDRam sticks (768 total Ram)
Geforce 4 TI 4200 w/128M ram
Sound Blaster PCI512
Maxtor 20G HD
TDK 52x24x52 CD-RW
3Com 10/100 905b NIC
Running Windows 2000 as a "Standard PC" not "ACPI"

This is the basics, as you don't need to know what I have
on the RAID side of things for HD's, as they don't factor
into the problem.

When I started getting them, I re-installed and repatched
from the ground up on the computer - still got them.

Yesterday (10/8) I reinstalled my computer as a "Standard
PC" with the Geforce 4 at IRQ 5, SB PCI512 at IRQ 9, and
the NIC at IRQ 11. Please note, that with the "Standard PC"
setting in Windows 2000, it accepts the BIOS settings,
instead of "assigning IRQ" as per the OS. I still can't
change the damn IRQ's from within the OS, but at least I
know they are all on seperate IRQ's, as per system.

Anyway, after re-installing, installing drivers for the RAID
and video card and sound card and patches for the OS and
installing only DirectX 8.1 and NVidia 40.72 Drivers for
the video card - As the 45.23 Drivers and 43.XX drivers
just caused even bigger problems, I loaded the game, patched
it and the started it.

The first time it started, I got into the "LAN" game
settings and started making changes, when I got an actual
"Blue Screen of Death" - nt4_disp.dll was the cause.

Ok, I restart my computer and start up RS again, make my
changes and actually click "launch" and "play", when I
get a General Protection Fault - Main Loop. Please note,
there is NO EVENT ERROR! If there was, I could try to do
something else, but nada.

Third times a charm - I fire it up and get actually get
into the game and start to move around, when it dies with
another GPF.

This goes on for times 4 through 20. I stopped submitting
bug reports after the 10th time, as I was getting frustrated
and my language by this point in time had deteriorated to
that just shy of resorting to black magic and blowing the
company off the face of the earth. If there had been
any way I could have gotten into the game and actually
played, I would have wasted EVERYONE........


Anyway, I tried the FIX as posted in other notes, but that
didn't work.....

Help!

Casper /i/smilies/16x16_smiley-sad.gif

XyZspineZyX
10-10-2003, 02:23 PM
Well a couple of things I noticed. One "nt4_disp.dll" I believe is an nvidia driver, this may be corrupt or something. Two, your directX drivers do need to go up, I believe you have to have at least 9.0.

Remember this rule. . .

Just because it worked in/on someone else's computer does NOT mean it will work on yours!

Good Hunting!

XyZspineZyX
10-10-2003, 03:34 PM
KShot wrote:
- Well a couple of things I noticed. One
- "nt4_disp.dll" I believe is an nvidia driver, this
- may be corrupt or something. Two, your directX
- drivers do need to go up, I believe you have to have
- at least 9.0.
-
- Remember this rule. . .
-
- Just because it worked in/on someone else's computer
- does NOT mean it will work on yours!
-
- Good Hunting!


I was using 40.72 Nvidia drivers before I got the problem,
so, it shouldn't be the problem now. And well, RS
recommends 9.0 drivers, but will run with the 8.1 drivers.

You know, NOW that I remember, this all flippen well
started after the latest Micro$haft cumulative critical
update for IE was installed.

Hmm, I wonder. I'll get THAT cricital update and remove
it.... I wonder if that will fix the problem.

reply to: mrpietan@netscape.net

In game - Casper